BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk local server java error when starting

localserver
#1

Hello everyone, I just get an error with a blynk local server. before I have to run or success to run my local server blynk on my own cloud server. but I decide to delete all of my progress and re-build my local server again from 0. and I got this problem, I don’t find this problem before.


I’ve tried to run from root, or not. or just java -jar server.xxxx.jar but it doesn’t work.

0 Likes

#2

I’ve got a solution for this problem. there is written error cause access denied on report-email.html, so i change the permission of it to 777. then it successfully starts again

0 Likes

#3

As you’ve noticed yourself it’s a permission issue, and probably caused by PMAC. :wink:

Jokes aside, getting all permissions correct for a non root environment can be a bit tricky if you’re not used to Linux. I think I wrote a post on how I did it a long time ago.

[this is just me being annoying]

Never use 777. EVER!

@Gunner Err… should this topic be in Solved now (I don’t dare to change it)? I mean, it’s not an actual error even if the discussion can continue if needed. :slight_smile:

1 Like

#4

Thank you for your reply and now is solved. But idk how yo change into solved in this thread, can you help me?

0 Likes

#5

If you scroll up to the top of the topic there’s a pencil icon next to the title. Clicking this allows you to change the category to Solved (I’ve just done if for you though).

Pete.

0 Likes

#6

thank you very much pete

0 Likes