Blynk Library v0.4.0 is released

I am using Arduino mega with Ethernet shield.

Me too, but Eventor continues to work.

I’m getting this every now and then in Serial Monitor:

[42440] Packet too big: 30327
[42473] Connecting to 192.168.0.25:8442

Maybe it’s a clue?

This means data is corrupted somehow.
Iw you enable BLYNK_DEBUG you will see exact data - send it to me, better privately.

vhymanskyy,
I sent you my serial output.

Could this be a power issue?
Can you connect to a stable wall outlet USB power supply?

I also can’t seem to scroll back in the terminal widget, it keeps flipping back to the last line. Could be a code issue, but I doubt it should do this.

-edit-

And now it appears to run quite stable again, but not much changes made to code, let alone hardware. Only BLYNK_SERIAL as output now. I don’t understand… I’ll try to figure it out, but so far it’s a mystery to me.

Apparently there is a sort of flaw in the UIPEthernet library, according to https://forum.mysensors.org/topic/536/problems-with-enc28j60-losing-connection-freezing-using-uipethernet-or-ethershield-read-this/2 this webpage. I’ve implemented the mentioned fix in Enc28J60Network.cpp to see if it’ll help making the network adapter more stable.

@haidar23 could you make this change too? I’d like to have more than one reference to see if it fixes this stupid ethernet port issue :wink:

Same here.

so should i roll back to library 3.10 before i compile and upload any updated sketches to my hardware?

i have not uploaded any 4.0 sketches yet.

using various ESP8266 and one Arduino Mega with W5100 ethernet

If you are not using any Android sensors then I would say 4.0 is fine.

2 Likes

Pulling hairs out as we speak, The ENC is even more unstable than before. I even cooked up new plugs to exclude hardware failure. For now even an ESP-01 as shield is more stable than the ENC as it seems. Been testing stuff all day today, but got no further than yesterday. It’s completely useless now. My Arduino freezes up after about five minutes again and again.

@Dmitriy / @vshymanskyy let me know if I can sponsor you guys an ENC to test, because I’m getting crazy here! I have absolutely no idea what’s wrong. This should work fine, right? I tried the library hack I indicated somewhere above here, but that also doesn’t solve the issues. I’m using an external power supply, removed all other things, tried on other Arduino (fake and real one), two different ENC’s. Only conclusion I can come to now, it’s a software problem, but which software? I don’t know …

Sorry, I have an ENC, just can’t do that right now.

Lol, ok.

Anyway, I hooked up an ESP 01 to my Mega and ran into a nasty old friend called “buffer overflow”. So I took my 700 lines of code apart and added it one by one (horrible job!!!) but I found out it was the Blynk.syncAll() which caused the buffer overflow. When I sync my individual pins it goes fine, about 10 pieces, not sure how much it can handle in total.

Also, nice little trick I picked up. After starting your program with connecting and such, make a SimpleTimer function for a one-time timer to enable all other timers. This gives a little breathing room for the ESP. It appears to run much more stable now being in use as a shield.

It’s just the terminal now which is still acting weird, spitting out wrong stuff and too many lines, but I’ll be bothering myself with that another time. I found out enough stuff to keep us busy for one evening :wink:

1 Like

This is a very limited function and under the right circumstances can crash your hardware with just a handful of pins. Use with care and if possible sync the bare minimum of pins individually and at timed intervals if it causes problems.

Hello
Four days ago I lost communication between Wemos D1 and blynk server. The sketch is uploaded in the module with the previous blink library. To get back on line I have to upload the sketch again with the last v0.4.0 released library?
Thanks
catalin

You are advised to use the latest library wherever possible but it is not normally essential if you haven’t added any of the latest features to your project. When the server was changed 6 months ago you had to upgrade to the latest library. I believe there were also some “Time” changes made a few releases back too.

OK, thanks for the information. I think its better to not update the library for now and stay with the previous.
Why not go back to that version. I have my Mega running for 7 weeks now with any problem.
good luck and hope there will be a solution soon

If you time everything the right way, the 0.4.0 library rocks. It has been running very stable the last few days with my Mega using an ESP as shield, which is notoriously unstable, but now. It works like a charm.

-edit-

Can someone post a short example to read the Accelerometer? I’m afraid I threw my sketch away … :frowning: