Blynk Library acts really weird. Even the examples aren't compilable

i downloaded the Blynk library v0.3.8 and ran it with the Arduino IDE v1.6.10 and it worked fine, i made a sketch but forgot to save it (i did this on a Mac). Recently, i bought a Dell with Windows 10 and i downloaded Arduino IDE v1.6.13 to run Blynk library v0.4.2 and something weird happened. IT DIDN’T WORK AND STILL DOSEN’T WORK!!! i even tried to compile an example and it showed this error:

"Arduino: 1.6.13 (Windows Store (Windows 10), Board: “Arduino/Genuino Uno”

avr-g++: error: C:\Users\benng\OneDrive\Ta`i liê?u\Arduino\libraries\blynk_library_master\src\utility\BlynkDebug.cpp: Invalid argument

avr-g++: warning: ‘-x c++’ after last input file has no effect

avr-g++: fatal error: no input files

compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Uno.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences."

I tried everything i could find on the community and arduino forum. i tried adding the library manually, tried different versions of the IDE and the library, the same error keeps poping up.
Does it have anything to do with the name i put in for my documents files( it’s in Vietnamese)?

probably you have to reinstall everyhing or move it out of your one-drive.