BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk is Connected, but no Change in Output

I have been trying to connect my Arduino Uno through the USB serial for a few hours. The Arduino board seems to be connected to the serial port on my computer fine, and the app on my iPhone shows that my Blynk project is online. This is my first Blynk project, so I am trying to get the most basic example program to work that is provided online with just a virtual button to turn on an LED from digital pin 8 on my Arduino. There are no error messages, so maybe it’s just not communicating over the right port? How do I determine which port I need to use?

I have gone through the entire process 3 times on the Blynk site as well as viewing numerous YouTube videos on how to make it work. I would greatly appreciate any help on this.


/*************************************************************
  Download latest Blynk library here:
    https://github.com/blynkkk/blynk-library/releases/latest

  Blynk is a platform with iOS and Android apps to control
  Arduino, Raspberry Pi and the likes over the Internet.
  You can easily build graphic interfaces for all your
  projects by simply dragging and dropping widgets.

    Downloads, docs, tutorials: http://www.blynk.cc
    Sketch generator:           http://examples.blynk.cc
    Blynk community:            http://community.blynk.cc
    Follow us:                  http://www.fb.com/blynkapp
                                http://twitter.com/blynk_app

  Blynk library is licensed under MIT license
  This example code is in public domain.

 *************************************************************
  =>
  =>          USB HOWTO: http://tiny.cc/BlynkUSB
  =>

  Feel free to apply it to any other example. It's simple!
 *************************************************************/

/* Comment this out to disable prints and save space */
#define BLYNK_PRINT DebugSerial


// You could use a spare Hardware Serial on boards that have it (like Mega)
#include <SoftwareSerial.h>
SoftwareSerial DebugSerial(2, 3); // RX, TX

#include <BlynkSimpleStream.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "OZT4CEfgE7YabsKLluLq2buefmkzvofN";


void setup()
{
  // Debug console
  DebugSerial.begin(9600);

  // Blynk will work through Serial
  // Do not read or write this serial manually in your sketch
  Serial.begin(9600);
  Blynk.begin(Serial, auth);
}

void loop()
{
  Blynk.run();
}

This is the output for my blynk-ser.bat file.

You appear to have edited your blynk-ser.bat file to use port 8442. Where did this port number come from?
What happens if you try port 8080 or possibly port 80?

Pete.

Thank you Pete for your reply.

I did edit the blynk-ser.bat file to port 8442 based on one of the tutorials I saw on Instructibles (https://www.instructables.com/id/Control-arduino-using-Blynk-over-usb/). I actually followed this tutorial step by step but didn’t get the same result as him.
I did also try port 80 and port 8080 before since I saw other tutorials that used those ports. And I just retried those ports again now, but I saw no difference in anything.

I notice that your IP address says that you’re at a university.
I guess it’s possible that some of the Blynk traffic is being blocked by the university firewalls/filters or their ISP.

Are you able to try with a computer that’s connected to a domestic network?

Pete.

1 Like

Yes, that is a possibility that I forgot to consider…
I can try to connect to another off-campus network tomorrow, and I’ll reply with how it turned out. That may be what the issue is.

Problem solved! Thank you, Pete.
I tested the Blynk project at a nearby McDonald’s WiFi network and it worked. So, like you said, I think the university firewalls/filters are preventing Blynk communications.

1 Like