BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk HTTP RESTful API

notifications don’t work with the API and the URL http://blynk-cloud.com/4ae3851817194e2596cf1b7103603ef8/notify the apiary tests don’t work too, I always get the invalid token error.
I have to use: 139.59.206.133:80 instead of blynk-cloud.com to make it work.

Anyone else experiencing the same problem?

It’s a known issue, because your project and its associated auth token only exists on one of the three global cloud servers and a remote server may resolve blynk-cloud.com to a different server. There is a warning about this in the documentation…

HTTP RESTful API

Blynk HTTP RESTful API allows to easily read and write values of Pins in Blynk apps and Hardware.
API description can be found here. Warning : Blynk HTTP API still has GEO DNS issue. This means, for now you need to use direct server IP instead of hostname in order to make it work with 3-d party services like IFTTT.

Pete.

Hi Pete,

I have integrated blynk into my project several years ago and it was working well until recent time. Some users of my project have enabled blynk data forwarding where my project forwards their sensor data to blynk via HTTP Rest API.
How do i know which server has my token and why are those servers are not synchronized.

Thanks,
Oleg

You’d normally ping blynk-cloud.com from your home PC to obtain the IP address - as I guess you did.

I don’t think it’s really practical. Doing real-time synchronisation between three servers in different parts of the world wold defeat the purpose of having three servers - which is to reduce latency between the app and the device.

Pete.