BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk (homepage) Widget (suddenly) not working

android
esp8266
localserver

#1

hello there.
i use blynk for IoT home.
with ESP8266(d2mini)
server at RPi local server (java8, 0.41.1)
blynk app is up to date (2.27.1)

all works well, but, suddenly, Android Widget of Blynk not working on my Samsung Galaxy S7 Edge (Android 8.0)
in the app, it works well. only Widget not working.
i need widget of normal button and styled button, but both not working…

i tried delete widget and recreate it, doesn’t work.
i tried delete app and recreate it, doesn’t work.
i tried on other phone(Xiaomi Redmi note 4x, android 7.0), it works well.
i tried local Server http api with PostMan (PUT http://server.com:8080/“api-keys”/update/V2), it works well.

so it seems to problem of my phone(S7E), but i can’t not find out problem.
can you help me…?
it is too strange, it worked well one week before… none of my environment changed(android os version, server version, app version… etc)


#2

There are many widgets in blynk… which particular one are you referring too? Also, is this a widget in a project or on the phone’s homepage?


#4

i mean, “widgets” on android home launcher.
button, labeled value, led, styled button… nothing works…


#5

OK, if it seems limited to that phone, then where there any recent OS updates to it? You might have to go through App permissions again.


#7

thx for replay.
there is no OS update on my phone.
i already allowed app permission after reinstalling blynk app in Phone’s app settings


#8

Well… it still sounds like a phone related issue not a Blynk specific one, as there has not been any recent Blynk updates either (that I am aware of).

I guess you could try using the widgets a few times, then send a log report.


#9

how can i get log?
you mean, server log or app log?


#10

Send log not get, and yes App log… After trying the widgets, click to the project changer mode and click on the [i] in the upper right corner and chose Send logs to Developer and include references to this topic and details of the widgets tried and any other specifics.


#11

oh, suddenly, it work again…
i have no idea why it work again… ;-?

anyway, thanks for support!