Blynk.Edgent Error - won't connect with error code 701

I am attempting to use my Arduino Nano 33 IoT board to connect to Blynk with Blynk.Edgent; however, I keep getting 701 errors that the board isn’t able to connect.

Here is my code for the main Edgent file:

 * Required libraries:
 *  - WiFiNINA
 *  - ArduinoOTA
 *  - ArduinoHttpClient
 *  - Timer5
 * Please also update the WiFi module firmware, if needed

// Fill-in information from your Blynk Template here
#define BLYNK_DEVICE_NAME "Aquaponics System"

#define BLYNK_FIRMWARE_VERSION        "0.1.0"

#define BLYNK_PRINT Serial
//#define BLYNK_DEBUG

#define APP_DEBUG

#include "BlynkEdgent.h"

void setup()


void loop() {;

And here is the output:

[99091] Sending board info...
[129231] Sending board info...
[129361] Sending networks...
[140697] Applying configuration...
[140699] WiFi SSID: **** Pass: *******
[140699] Blynk cloud: [I'm hiding my auth] @
[140704] Switching to STA...
[141706] Connecting to WiFi: ****
[205124] Last error code: 701
[205126] Configuration stored to flash
[215134] Restarting after error.

I should note that I have not been able to find an Edgent file for the Arduino Nano 33 IoT, so I am using the Arduino MKR1010 file for Edgent that I found other people have seemed to have some luck with on my board.

please edit your post, using the pencil icon at the bottom, and add triple backticks at the beginning and end of your code so that it displays correctly. Triple backticks look like this: ```

ok, just did.

Are you connecting to a 2.4GHz WiFi network?

Error 701 means that the board couldn’t connect to the WiFi network…

This might be because your SSID or Password are incorrect (both are case sensitive) or you are trying to connect to 5GHz WiFi network with a board that only supports 2.4GHz.

If it’s neither of those issues then I’d start by rebooting your router and any wireless access points on your network, ensuring that your board is getting a good WiFi signal, and ensuring that you’ve done this…


Hi Pete,

My network is 2.4GHz and 5GHz. I’ll try turning off the 5GHz for now and see if that helps.

I’ve tried this with the code for programming the wifi module loaded onto the board, and yet I still get an error saying error resetting flash.