Blynk does not give ESP8266 Offline when ESP8266 is powered off

I have an ESP8266 project that was working fine and then stopped. I have 3 projects and when I turn the power off to two of the ESP8266s I get the ESP8266 offline error which is normal. However, one of the projects continues to act likes it’s working when I run Blynk - I don’t get the ESP8266 Offlline error - even when the ESP8266 is not powered up.

I’ve reprogrammed the ESP8266, uploaded a new Auth code and it still does the same thing - acts like it’s working when I know the power is turned off and I should get the EPS8266 offline error.

Thanks for any help with this.


Hello. Do you use same auth code for all ESPs?


It shows you as a co-founder - first off THANK YOU for such a great project - I love BLYNK!

Three ESP8266s with three different Auth codes. One showed no offline error the other two showed ESP8266 offline correctly when they were turned off.

So this is what I tried. I loaded the stand alone ESP8266 with the project that wasn’t giving me the offline error and nothing worked even when I added a pushbutton and slider.

I then loaded the ESP8266 stand alone with one of the other two projects (same ESP8266 but with a new Auth code) then added a pushbutton and slider - worked perfect and verified with an O’scope. Serial printout confirmed connection - but the serial printout confirmed connection on the one that wasn’t working as well.

I did have all three projects offline for about 3 months as I was working on other things. I got a new WiFi router but serial print confirmed connection to both WiFi and Blyink.

I updated Blynk library for the following tests.

Project 1: Does not give offline error meaning it is connected but does not respond to any Blynk commands. Tried new Auth codes but nothing. Loaded ESP8266 stand alone with new Auth code - still nothing.

Project 2: Loaded ESP8266 stand alone with new Auth code - worked like a champ. Correctly shows offline error when ESP8266 is not powered up.

Project 3: Loaded ESP8266 stand alone with old Auth code - O’scope and serial print confirms connection to Blynk and correct response, however, if I turn the ESP8266 off I don’t get the offline error like I did before.

Old Auth codes are at least 9 months old. New Auth codes were generated within the last couple of days and loaded to the ESP8266.

Projects on iPhone are at least 9 months old.

Same ESP8266 was used for all three project tests during the last couple of days - uploaded new code to the ESP8266 each time.

Hope this helps explain some of the outputs I’m getting. I was trouble shooting as I wrote this so may seem a little disjointed.


Correction - Project 3 now shows offline when ESP8266 turned off so it is working correctly - must have been some latency in status.


Is it connected at all?

This is the serial output I get:

#Y6†ÖYy–¶–‹„îHú[274] Connecting to “My WiFi”
[3774] Connected to WiFi
[3774] IP:
[3775] Blynk v0.4.0 on ESP8266
[5001] Connecting to
[5120] Ready (ping: 2ms).

I deleted all the widgets and reinstalled some new ones - button and slider but nothing.

Does not give the offline error when ESP8266 is powered down. Really weird.

By the way an idea for a new widget would be a “Servo Widget”. I looked at the timing for the PWM but maybe you could set up a widget for a 1ms to 2ms on pulse with a 20ms total pulse width. Then you could hook a servo directly to one of the pins.