BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk crashing Particle Photon


#1

I have been using Blynk for a couple of years now - largely for creating demo videos for my company’s IoT hardware products. However, last weekend, I ran across a new and discouraging behavior while attempting to use Blynk with a Particle Photon on a project I was developing at home.

I’ve used Blynk with Particle devices many times in the past without issue - including for a couple of days last week when I was first playing with this new idea. But then over the last weekend, everything stopped working, and I started to get this “crashing” behavior.

After spending some time trying to isolate the issue and boing back and forth with different versions of Device OS on the Photon, I have a very repeatable process to make it fail. The failing/crashing symptoms are:

  • Photon disconnects from WiFi
  • Cyan status LED switches to slow dark blue Listening Mode blinking
  • Then status LED transitions to rapid dark blue blinking pattern
  • WiFi credentials are erased, and I need to go through the WiFi setup process again AND re-flash the program with a safe program (Tinker) that does not start Blynk. Otherwise, the process will just repeat itself.

Here’s a video of the setup and steps that cause the crash: https://youtu.be/flr_34Bg4Fk

Some additional info:

  • Hardware: Particle Photon
  • Photon Device OS Version: 0.7.0
  • Blynk Library: 0.5.4
  • Blynk Server (Not local)

The code is from the Getting Started code builder on Blynk.cc:

/* Comment this out to disable prints and save space */
#define BLYNK_DEBUG
#define BLYNK_PRINT Serial

#include <blynk.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "[REMOVED FOR POST]";

void setup()
{
  // Debug console
  Serial.begin(9600);

  delay(5000); // Allow board to settle
  Blynk.begin(auth);
}

void loop()
{
  Blynk.run();
  // You can inject your own code or combine it with other sketches.
  // Check other examples on how to communicate with Blynk. Remember
  // to avoid delay() function!
}

Any thoughts or ideas are welcome!

Thanks!
Jason


#2

Try the Blynk 0.5.1 library. I’ve had troubles uploading with 0.5.3 with Particle web IDE. Haven’t tried the 0.5.4 yet.


#3

Thanks for the suggestion. I just tried that, but I got the same result.

I appreciate the idea!


#4

I don’t think Blynk has published any changes recently… has Particle? How about local PSU or WiFi changes?


#5

Good thought. And in fact, I think this is most likely a Photon issue and not Blynk because Blynk has been rock solid for me for a long time. However, I wanted to post here in case anyone has seen something like this before.


#6

Solved this problem by upgrading my Photon to DeviceOS 0.8.0-rc12 at the recommendation of a response I got on the Particle Forum thread:

Jason