Blynk connect and then disconnect

Hi,

Today I uploaded a new sketch to my NodeMcu and it’s connected succsessfully. 3 seconds later the board disconnected. After that I uploaded the “blynk blink” example but the same thing happened. When it disconnects, serial monitor always write some characters at the end but I don’t know what it is. Anyone know about this thing?
My serial monitor:

[18470] Connecting to HUAWEI P10
[18973] Connected to WiFi
[18973] IP: 192.168.43.170
[18973] 
    ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v0.5.1 on NodeMCU

[19048] Connecting to blynk-cloud.com:80
[19201] Ready (ping: 49ms).
?)1

Those might be info ESP is throwing right after reboot at 74880 kbps. Nothing more can be said as you have provided no info at all.

did that board ever had a lasting connection before?

if yes, what did you changed since than in hardware side?

  • try to disconnect everything from the board and test connection

  • try a different psu

if not, try the exact same setup with a different esp8266, to make sure the board is not defective

  • post some details about the hardware setup

I had no problem with it before.
I have two nodemcu, and both of them do the same. I also tried another psu so I have no idea. Currently there is nothing connected to the board.

What happens if you change the serial baud rate to 74880 in your sketch and recompile and re-flash your device(s)?
Does the serial output provide any more detail?

Has anything else changed? Changes to router settings, any new devices attached to your network etc?

Are you explicitly specifying the IP for the devices, or letting Blynk handle this automatically via DHCP?

What happens if you enable Blynk Debug?

Pete.

Ahh, goody… another “it broken, why?” without any usable details topic… We don’t get enough of these :stuck_out_tongue_winking_eye:

What did you change, or allow to change, since “before”? In fact, when was “before” and what was it doing with “no problem” at that time?

Thank you for the advices.

I’m tried two different NodeMcu at two different network with two different PC/arduino ide, but the same result.
At 74880 the device connects, then the same thing as before with more characters, but at 115200 baud rate this is added to serial monitor:

wdt reset
load 0x4010f000, len 1384, room 16
tail 8
chksum 0x2d
csum 0x2d
v4ceabea9
~ld 0x2d
v4ceabea9
~ld

or

ets Jan 8 2013,rst cause:4, boot mode:(3,7) wdt reset or
ets Jan 8 2013,rst cause:4, boot mode:(1,0) wdt reset or
ets Jan 8 2013,rst cause:4, boot mode:(1,4) wdt reset

and in some cases repeat connection.

Yea Gunner, you are right, but I didn’t know what else to say…
I haven’t changed anything serious on my setup in the last month, except I added cayenne library and connected my Uno.
When I said “before”, I meant that before yesterday, so before this I tried to read ds18b20 thermometer.

Normally a recipe for disaster.

Yes, read about it later, so I’ve deleted the library.

1 Like

For ESP in Arduino IDE there exists quite handy exception decoder. I do remember once it helped me quite a lot. You may want to try that.
For now it looks like a wdt triggers for some reason.