Blynk cloud websockets not working right now?


Are the blynk cloud websockets not working right now? I’m experiencing similar problems as mentioned by Pathway with his local server earlier this month.

Websocket outputs to blynk are listed as disconnected in node-red, flow was working flawlessly for over a month , using ws:// All my other ESP’s using blynk without MQTT are working fine.


Should be ws://

Thanks! that fixed it! Weird that it did work for quite some time with websocket instead of websockets

I did a typo during one of releases (0.19.0 I guess). And after that there was wrong path. After 0.20.1 release many people reported issue so I reverted this typo back for back compatibility.

FYI: Yesterday I too noticed my Blynk app wasn’t working anymore. It said “device not connected”. As I don’t use the app on a daily basis, it may have been inoperational for some days or even a couple of weeks.

In Node-RED I saw error messages on every Blynk node, so I consulted the forum. I too had the old /websocket url, but changing it to ws:// wasn’t sufficient. Restarting the app or Node-RED also didn’t help.

Eventually I had to recreate the app and use the newly generated project key to get it working again. Configuring a new app and adding all the widgets in the Blynk app and recreating all the Blynk nodes was a bit cumbersome, but it did the trick and now the app is working again.

Hey guys. I just set up a brand new app and node (in node-red), and the ws:// address still doesn’t appear to work. Even when I try to create a generic websocket connection using, I get a blanket “DISCONNECTED” error. Anyone able to get this address to connect?