Blynk Board Not Functional

I ordered the Blynk Board from Sparkfun here I downloaded the app on my iPhone, plugged the board into my computer, opened the app, scanned the QR code and began the provisioning process. It all went well until I noticed a couple of strange things.

1.) The blynk board does not show a special four colored code using the LED. instead it flashes red,green, and blue in that order.

2.) The wifi settings on my iPhone do not show any kind of network named BlynkMe-CCCC or any other color combination, instead the wifi network that shows up is named ESP_E2A92C.

I attempted to connect to the network to see if it would work but the Blynk app keeps saying that the blynk board is offline. I opened up the com port using arduino and this is the message it gave me.

[1344] SparkFun Blynk Board Hardware v1.0.0
[1345] SparkFun Blynk Board Firmware v1.0.2
[1368] Performing self test
Failed to connect to WiFi
Si7021 test succeeded
ADC test failed: 3.20
IO test failed

I emailed the blynk support staff about this and they suggested that I “re-flash the board with the firmware provided by SparkFun, or you can simply try connecting to this WiFi and check if provisioning works”. Of course, connecting to the wifi does not work so I set out to re-flash the firmware.

I downloaded the firmware from here I then installed the blynk board addon in the arduino IDE, opened the firmware file in the arduino IDE and uploaded the firmware onto the blynk board using the arduino IDE. (Sorry, I can only put two links in a post).

The result was the same, the COM messages are the same, the LED on the board is still only blinking in the same pattern of Red, Green, and Blue, and my iPhone still cannot connect to it even if I try to provision the board again.

I tried to upload a sketch onto the board using the instructions found on the bottom half of this page The sketch provided uses the following code:

    #define BLYNK_PRINT Serial    // Comment this out to disable prints and save space
    #include <ESP8266WiFi.h>
    #include <BlynkSimpleEsp8266.h>
    #include <Adafruit_NeoPixel.h>

    // Blynk Settings //
    char BlynkAuth[] = "Your_Auth_Token";
    char WiFiNetwork[] = "Your_WiFi_Network";
    char WiFiPassword[] = "Your_WiFi_Password";

    // Hardware Settings //
    #define WS2812_PIN 4 // Pin connected to WS2812 LED
    #define BUTTON_PIN 0
    #define LED_PIN    5
    Adafruit_NeoPixel rgb = Adafruit_NeoPixel(1, WS2812_PIN, NEO_GRB + NEO_KHZ800);

    BLYNK_WRITE(V0) // Handle RGB from the zeRGBa
      if (param.getLength() < 5)

      byte red = param[0].asInt();
      byte green = param[1].asInt();
      byte blue = param[2].asInt();

      uint32_t rgbColor = rgb.Color(red, green, blue);
      rgb.setPixelColor(0, rgbColor);;

    void setup()
      // Initialize hardware
      Serial.begin(9600); // Serial
      rgb.begin(); // RGB LED
      pinMode(BUTTON_PIN, INPUT); // Button input
      pinMode(LED_PIN, OUTPUT); // LED output

      // Initialize Blynk
      Blynk.begin(BlynkAuth, WiFiNetwork, WiFiPassword);

    void loop()
      // Execute as often as possible during the loop; 

Of course I copied my auth token and used the correct network name and password when I uploaded the sketch.

Nothing has worked. When doing this experiment, all the COM port showed was:

[342] Connecting to "the name of my network"

and nothing else came up.

After that did not work I reuploaded the spark fun firmware onto the blynk board and got it back to doing the same thing from when I received it in the box. What else can I do to get it to work?

Have you also contacted SparkFun Support? They might be in a better position to assist in case of board related issues.