Blynk BLE Widget won't Connect to DFRobot Bluno

Hi Blynkers!

I have just got a DFRobot Bluno in the mail and am trying the basic bluetooth sketch found in “/Blynk/Boards_Bluetooth/DFRobot_Bluno_BLE_Link.ino” but am getting nowhere.

I set up a new device as Arduino Uno with connection type as BLE. I pasted the auth into the example sketch, and uploaded it to the Bluno.

I have a iPhone SE. I can connect to the Bluno in “Settings - Bluetooth” but on the Blynk app under the BLE widget, it does not connect.

I selected the “Connect BLE device” button in the widget, and a dropdown menu appears with all bluetooth devices in range. A device shows up as “Bluno” so I click on it, and after about 20 seconds of “Connecting…”, it says “Can’t connect. Please retry or choose another device.”

What am I doing wrong?
Thanks in advance!

Providing the information that was requested when you created this topic would be a good starting point…

  1. Add details :
    • Hardware model + communication type. For example: Arduino UNO with Ethernet Shield
    • Smartphone OS (iOS or Android) + Blynk App version
    • Blynk server or local server
    • Blynk Library version
    • Add your sketch code. :point_up:Code should be formatted as example below.

Simply paste your code between ``` If you don’t format your code, your topic can be deleted by moderators.


Your code in here



Bluno V2.0 BLE
iPhone SE completely upgraded.
Blynk Server.
Blynk Library Version: 1.0.1

  Blynk is a platform with iOS and Android apps to control
  Arduino, Raspberry Pi and the likes over the Internet.
  You can easily build graphic interfaces for all your
  projects by simply dragging and dropping widgets.

    Downloads, docs, tutorials:
    Sketch generator: 
    Blynk community:  
    Social networks:  

  Blynk library is licensed under MIT license
  This example code is in public domain.


  This example shows how to use DFRobot Bluno or BLE Link module
  to connect your project to Blynk.

  Please be sure to update your DFRobot firmware to at least V1.97:

  For Bluno, read instructions here:

  For BLE-Link, read instructions here:

  NOTE: BLE support is in beta!



// You could use a spare Hardware Serial on boards that have it (like Mega)
#include <SoftwareSerial.h>
SoftwareSerial DebugSerial(2, 3); // RX, TX

#define BLYNK_PRINT DebugSerial

/* Fill-in your Template ID (only if using Blynk.Cloud) */
//#define BLYNK_TEMPLATE_ID   "YourTemplateID"

#include <BlynkSimpleSerialBLE.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "*****************************";

void setup()
  // Debug console

  DebugSerial.println("Waiting for connections...");

  // Blynk will work through Serial
  // Do not read or write this serial manually in your sketch
  Blynk.begin(Serial, auth);

void loop()

Still don’t know which flavour or version of the Blynk app you’re using.


Sorry. Blynk App Version: 2.26.8

Try to use blynk library version 0.6.1

Thanks for the suggestion @John93 . I just tried that version with no different results.

Is that Android or iOS ?



9 post later and we finally have the info that should have bern provided in post #1


I assumed that if is said I had an iPhone, it would be implied that my Blynk version is for iOS, not android. I already said I was using an example for my code and where it was located in Arduino IDE. I didn’t think I would need to paste the example. I already said I had an iPhone SE in my first post, and that I was using a Bluno with BLE.

~90% of your requested information was in my first post.

Have you tried to update the firmware ?

The firmware for the Bluno? No I haven’t. I did see that there was a version 2 update for it with directions on how to do that but I haven’t done it yet because I didn’t think I absolutely needed to. Should I try that? :thinking:

You can find everything here :

I saw that website. I tried to follow along but didn’t get very far because it uses an Android device. Instead I followed this page because it utilizes Blynk and can work with an iPhone.

You don’t need any phone ( android or ios ) to update the firmware.

Yes, I know. Just a computer. Here is the link:

I’ll try it now. Hopefully it fixes the problem. :woozy_face:

I would recommend you to use esp32 instead of this board, and I recommend you to use blynk iot instead of legacy.


Would using an ESP32 instead fix this problem? I have used Blynk for a while but never with Bluetooth. I haven’t switched to Blynk IOT yet because it cost a monthly fee. Their Legacy system uses a token system where you pay for each widget you use. I already bought a LOT of tokens on Legacy that would be useless with IOT’s monthly payments.

No BLE support in Blynk IoT, and no plans to implement it at the moment.

BLE in Legacy does work, with the correct hardware, but not reliably enough for it to be of interest to serious users.