Blynk apps stopped working on iPhone

All my Blynk apps have stopped working on my iPhone. Pressing the run button shows “Particle Photon is offline” on any of the various Photons implementing the apps. But they are clearly online and responding to other inputs over WiFi. The legacy apps use version 3.4. I"ve tried 3.7 with no help. The iPhone app is version 2.3. Suggestions welcome.

Result is same? Can you please show us some debug/serial output from your photon?

1 Like

OK. I’ve got a little test program working with 3.7. Can I assume I need to rebuild the 3.4 programs with 3.7?

OK. I rebuilt the rest of the programs with 3.7 and they are working. Can we get some kind of notice that needs to be done when it does?


I’m having the same issue. Could you share which 0.3.7 lib elements you had to add to your .ino to get it work? The current Blynk version out on the dev site is 0.3.5.

Remove Blynk library from existing app
Manually remove all the headers if they are still there

Search for Blynk Library
Check the version by pressing “i”

add to app
reflash the device

Worked on all of my Photons

Okay. I reflashed and still when I push a button widget button, nothing happens. Just two day ago this code worked fine. I’m still using .50 version of the Photon firmware and now (see below) 0.3.6 of the Blynk lib, but still its not working. I placed a Serial.println in my loop function and it prints over and over again, so I know that not a problem. When I press the run icon inside the project, it always comes back and says. Particle Photon is offline. if that was true, would I be able to flash it without a USB connection?

Its like the connection between the photon itself and the Blynk server isn’t happening. That’s my best guess now. I have another photon and it sketch is still working with Blynk.

Put a delay in the setup function, on the beginning, so you can see the connection log in the serial port.
Please ensure you have the right Auth token in your sketch.

I got the 3.7 library from GitHub, then modified it to work with Particle Dev. In particular, I flattened the library structure into a single directory and edited the includes to remove the directory references, e.g. changed #include “Adapters/foo.h” to #include “foo.h”. I’ll try to put the new version on GitHub when I get a chance. Probably not today. But it was only about 10 minutes work and all was well.

Not sure if this (see below) what you were talking about, but here’s my includes,defines and setup function. The only thing that I can see on my terminal monitor is the Serial.println that I’m doing in my set_volume function and Execute CMD function. Nothing else gets displayed.

#include "blynk/blynk.h"

#define BLYNK_DEBUG // Optional, this enables lots of prints
#define BLYNK_PRINT Serial

# define Start_Byte 0x7E
# define Version_Byte 0xFF
# define Command_Length 0x06
# define End_Byte 0xEF
# define Acknowledge 0x00 //Returns info with command 0x41 [0x01: info, 0x00: no info]


char auth2[] = "auth code";
char strout[35] = "";
int buttonNext = D2;
int buttonPause = D3;
int buttonPrevious = D4;
int volup = D5;
int voldn = D6;
boolean isPlaying = false;
int nxt = 0;
int pse = 0;
int prv = 0;
int vup = 0;
int vdn = 0;
int vol = 20;

void setup ()
  pinMode(buttonPause, OUTPUT);
  pinMode(buttonNext, OUTPUT);
  pinMode(buttonPrevious, OUTPUT);

okay. looks like my photon is the problem. I took an electron that I had and flashed it, its working without any issues. The only difference between the photon and electron is how it gets to the cloud, so I’ll see if I can get Particle help me with this hardware issue.