BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk app saying no internet

5 devices all on the internet all have the blynk app saying no internet…
all 5 devices have up to date app!

Since your issue sounds like somthing new and related to your own setup, I moved this into your own topic… any further details you can provide will help others to assist.

I have the same problem. In the last months I had sometimes for hours no connection from 2 iPads an 1 iPhone to the local server app. Then last week definitely no connection any more, but raspberry pi is connected to WiFi.
—> Raspberry reset, installation newest software on local server, new installation of Blynk App on Apple-Devices: everything worked well - for 2 days!
—>Since yesterday again no connection. I have no idea any more…

It sounds like a local networking issue, which is almost impossible for us to help diagnose.
Things to check/try…

Is the RPI’s IP address changing?

Have you rebooted everything?

Is your router misbehaving?

Are you using the IP address of the RPi or a DDNS url in your customer server settings? If the latter then try the IP address.

Do you have a dual band router? If so then do you have network segmentation between bands? This would prevent a device on one band seeing the RPi on another band.

Pete.

Hi Pete,
thank you very much for your reply.
I ckecked all your proposals and found out that everything works fine with a LAN instead of WLAN Connection!
My FritzBox shows with LAN: Connection and Internet Access
with WLAN: only Connection
between Router and Pi.
I will observe the stability of the whole system in the next days and then I try to solve the WLAN problem.
Again thanks and best regards.
Lutz

Has this worked before, or have you recently changed ISP?
It’s possible that some ISPs might block the Blynk traffic.

Other things to check are obviously that all the correct ports are being forwarded to your Blynk server, and that your app is hitting your router, with via a static IP or DDNS service.

Pete.

Yes, the whole system worked very well in the last years - except sometimes relatively long login times (seeing the turning green balls).
In the last week Login was impossible (no new ISP). After resetting Pi, new OS, latest Blynk Software the System worked ok. Then on Sunday again login impossible. You know the rest of the story.
Up to now with LAN connection login is very fast and still working…
Regards
Lutz

And this bit?

Also, have you tried rebooting your router?

Pete.

I`m using a static IP-address for the Pi and yes, I rebooted the rooter yesterday.
Because we are several days not at home I will try the WLAN connection instead of the LAN connection when we are back. Keep you informed.
Many thanks for the advices!!

But is your WLAN IP address static?

If not then you’ll need a DDNS service and a client that updates that service with your new public (WLAN) IP address every time it changes.

Pete.

im a senior network engineer for a 16 billion dollar in sales company
i would have made certain my home network is golden before posting.
obviously the issue is external to my home network