Blynk app not connecting with local server through hotspot

I have turned on hotspot from another android mobile and am using it to connect my blynk app installed on other android mobile to connect it to my local server on my laptop but it fails to connect and is trying again and again to connect to local server. So what i should do Please help me out in this one
and i am using arduino serial connection

Please don’t “spam” user requests… we all see the same topics.

Your issue is most likely due to the rather complex way you are running a network, your “hotspot” goes through your carrier’s network, so not a direct connection to the same network as your Local Server. You could try to setup proper NoIP DNS redirection setup and Port Forwarding for your Local Server, but overall networking 101 is a bit beyond what we do here.

Thanks for the reply bro
I do run complex network because in my working area the router doesn’t permit me to connect to my local server so i moved on to the next option i.e hotspot but i lack it on my android on which blynk is installed and i have on the other one so thats the reason i used that network. But the point i wanted to clarify is that if i run the blynk app on the same android on which hotspot is available will it connect to local server b/c now all in vain i have tried it several times but no help. But unique thing that i have noted is that it do connects to blynk server but not local server so whats that all about. And one thing more whenever i use my router connection at my home on both my android and laptop it connects successfully without any problem. Please bro i am stucked here.

Kay bro i have solved it just change some permission settings and installed blynk app on the other android and it worked out. By the way Thanks

Sounds like you have already worked a solution; But to answer this question, it is becasue your hotspot links your phone to the internet, where the Blynk Cloud resides, however your Local Server resides in your internal network, thus segregated from the internet and unavailable without linking the App to your router’s public IP (or using No-IP redirection) and using port forwarding in your router… basically like watching your own TV by running over to the neighbour’s couch and peering through his and your own open windows :stuck_out_tongue: