Blynk APP Crashes on startup

IOS 12.4, Blynk Version 2.26.0

Recently started noticing instability on IOS 12.4, Iphone 8 plus.
The blynk app would crash right after opening to browse my projects. I have two Iphone 8 plus running 12.4 and it’s happening on both. Is this happening to anyone else?

@Eugene please take a look.

Does the crash happens every time you open the Blynk app?

If so, please try removing the app and install a fresh copy from App Store.

Yes. It would happen over and over even after re-installing on both devices. I am using blynk today and it seems to be fine now. No updates either on IOS or Blynk but its working, :astonished:


I figured the issue was resolved but it’s happening again.

Just providing additional information that I’ve noticed. The app seems to work fine while working from my iPad Pro (12.9 -inch) software IOS 12.4

From crash reports, looks like those crashes caused by the error in ui rendering on system level (not much helpful).
Maybe there were some changes (new project, new widgets, or perhaps new setProperty usage) before this started happening?

Anyway, if it’s possible, send us the logs from within the app to take a look.

I had similar issue - using iphone XR. But last few days it stopped. Weird.

I managed to see issue again - fixed only by hard restart (turn phone off and on). What was is app was running — Blynk app splash came up with a black screen then it went away and standard iphone home screen was shown - but interestingly blynk was still running in backgound.

@Eugene I will email you logs.

Hello guys,

I took a closer look at my apps and still haven’t found anything. I emailed my logs. Is there something to look for specifically within my apps/logs that would cause a crash on startup?

@yourideasvi I received the logs, thanks. If possible, please send new logs, but kill the app first. (so the logs include the app launch).

Also, please enable standard Apple crash reporting. To do so, go to System Settings -> Privacy -> Analytics -> Share With App Developers

I’ll also send you a pm.

Hello again,

The app doesn’t launch long enough to send logs.

Thank you for helping.

I’ve uploaded a new build 2.26.1 (4) in TestFlight with a possible fix. To try a build from TestFlight you need to join our beta-testing group via the link:

Since you have so many active projects, I’d suggest to keep Blynk logging off in your usual usage (to not increase the cpu load).

thank you so much Eugene. The fix seems to work. I am now able to launch and build in the 2.26.1(4). can you elaborate a little more about the possible cause of the crash?

I am facing the same issue with my ios on iphone 7 plus.
and also the widgets are not in sync anymore. i tried re-installing the app. But no use the crash on open is solved. But the sync is not working anymore. even on android.
I am facing this issue only after the update.

I had the same issue for few days. A reinstall did the trick

yep. tried the reinstall but it didnt work for me.

Can you elaborate on the issue you’re having.
By update do you mean iOS 2.26.1(4) from TestFlight?

Maybe there were changes to firmware, local server or smth?

ios - 2.26.0(9)
Android - 2.27.9(21.08.2019 16:52:29)
Server - Local

Server version?

What exactly is not syncing? Data in the app, or do you mean sync calls on the firmware?