BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk App can't connect to the Local Blynk Server

Welcome
I have a problem with conection my app to local server.
I spend three days to read posts on forum to test all posybilities but i still can’t connect.

Actual situation

  • I implement server properties of dev master

[doom369] resources /

  • I can start server

java -jar server-0.41.15.jar -dataFolder \Mateusz\Blynk -serverConfig \Mateusz\Blynk\server.properties

Blynk Server 0.41.15 successfully started.
All server output is stored in folder ‘C:\Mateusz\Blynk.\logs’ file.

  • I can logg in on lokal server on my PC.

I use App 2.27.25 from 10.02.2021

According to some post i try to connect usig configuration:
I tried :
127.0.0.1 and 192.168.0.111 (it is my PC IP )and ports / 9443 / 80/ 8080

without result ;/ (Can’t connect to server. Try later)

I tried also some test

comment admin root

#ADMINISTRATION SECTION

#admin.rootPath=/admin

According to log:

14:24:00.653 INFO - Using data dir ‘\Mateusz\Blynk’
14:24:01.360 INFO - Region : local. Host : 192.168.0.111.
.
.
.
14:24:05.204 INFO - HTTP API and WebSockets server listening at 8080 port.
14:24:05.206 INFO - HTTPS API, WebSockets and Admin page server listening at 9443 port.
14:24:05.208 INFO - Mqtt hardware server listening at 8440 port.

Server start on my PC with IP 192.168.0.111 and I should connect but:
this IP is not avaible

in Web Browser https://192.168.0.111:9443/admin does not exist

But I can open 127.0.0.1 without problem

My App still can’t connect to 9443 /8080 /80 port

Do You think that if i can’t connect to 192.168.0.111 after a comment of server.properties this could be a problem that App can’t connect my Local IP?

Or App has some problem?

Please HELP

Greetings

When you are trying to connect with the app, is your phone/tablet connected to the same network as your PC via WiFi (i.e, not connected to the internet via GPRS)?

With your phone tablet connected to the same network, can you open https://192.168.0.111:9443/admin in a browser on your phone?

If not, are you able to ping 192.168.0.111 from your phone?

The app will only connect via port 9443, so don’t waste your time trying other ports in your custom server settings.

What does the allowed.administrator.ips section of your server.properties file say?

Pete.

Thank you PeteKnight for answer

  1. I use only Wi-fi
  2. I can’t connect to https://192.168.0.111:9443/admin through phone
  3. I can’t PING 192.168.0.111 by phone

And then i realized that i can Ping only on one way.

Problem was Avast Program.

Thank you one more time

Problem Solved

1 Like