Blynk 2.0 + raspberry pi zero w

I am attempting to connect a raspberry pi zero to Blynk2.0. I have tried python and c++ approaches, and neither have worked. I can get it to load the BLYNK text at the start, but then it stalls, presumably trying to establish a connection. Currently, this is following the instructions and running the example here:
Has anyone gotten this to work?

You’ve obviously done a pip install blynk-library-python, which has installed version 0.2.0 of the Blynk Python library.

This is the old (Legacy) version of the library. You need version 1.0.0 of the Python library, but these files haven’t been bundled into a release, so you have to install them manually by copying them from here:

@vshymanskyy could you sort-out a v1.0.0 Python release on GitHub at some point please?



1 Like

Thanks! That did it, I appreciate the help. The instructions on the repository do not reflect this issue. IT recommends running pip install despite it loading in the old version.

I am still having the issue with the c api, but this one seems differed. Why might I be seeing a result like this?

Read this,…


ok, thank you. I will dig into that. I had attempted to test out the example in provided in the library, and it must be also out of date.

Which example is that?


This one here: blynk-library/linux at master · blynkkk/blynk-library · GitHub

Try this example

I am good on the python api now, the second question was referring to C library.

I will be looking into this soon, along with some other ideas for the Python library