Blynk 2.0 Node-Red RasPi

My project has been running as expected for about four years. I upgraded my router and now Blynk IoT nodes do not connect. The error I receive is “Socket errorError: getaddrinfo EAI_AGAIN”. I did notice on Blynk Console the SSL IP is the old IP. My new router assigned a new IP, not sure if this is the cause.
Blynk ver 1.15.1
Blynk 1.0.0 IoT
Node-Red 2.0.6


I think that gets updated with your public IP when the device connects, so because it’s not connected then it’s not changed.
But, are you actually referring to your public IP address when you say…

or are you talking about a new internal zip address for your router?

I’d start by checking that the machine you are running Node-Red on can actually access the internet. If it can’t then you probably need to change your network settings on that device.

Without more info on the hardware and OS that you’re you’re using for your Node-Red server,m exactly what has changed regarding IP addresses, and what your network settings are on your Node-Red server it’s difficult to advise further.


I was referring to IP address dynamically assigned from my ISP. I am running Node-Red on a raspberry Pi. I did try pinging both and from a PuTTy terminal connected to my RasPi and received the error “Destination Host Unreachable”. The only change I made from my orginal setup was the new router and node-red dhcpcd.conf file. I orginally had local static ip address for node-red but by new router did not allow me to use that address so I changed it to in the dhcpcd.conf file. So you are correct it must be a network setting. I will keep researching thanks for your help.


You also need to include the new router IP address in dhcpcd.conf


This is a screenshot of dhcpcd.conf I only changed the one line

Using command ```
hostname -I

to find routers IP address command ```
ip r
to find DNS server command ```
cat /etc/resolv.conf
``` returned
Not sure what else needs to be changed any help would be appreciated.

I solved the issue. My new router LAN IP DNS started at
Thanks for the help