BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk 2.0 Invalid auth token on MKRNB1500

HI,
I have been using an Arduino MKRNB1500 successfully on the old blynk. Now that I’m trying to upgrade to the new blynk 2.0 I cannot make a connection. I always get the error “Invalid auth token”

Here is my test code just to get a connection.

#define BLYNK_PRINT Serial
#define BLYNK_TEMPLATE_ID "TMPL8XaCnT3n"
#define BLYNK_DEVICE_NAME "FieldSensor"
#define BLYNK_DEBUG

#include <MKRNB.h>
#include <BlynkSimpleMKRNB.h>

NBClient client;
GPRS gprs;
NB nbAccess;
// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "I have put the correct auth token in here";

char domain[] = "45.55.96.146";
char pin[]  = "";
int port = 8080;
void setup()
{
  // Debug console
  Serial.begin(9600);
  Blynk.begin(auth, nbAccess, gprs, client , pin, domain, port);
}
void loop()
{
  Blynk.run();
}

Have you tried using “blynk.cloud” instead of this IP address?

Pete.

1 Like

I have tried that.
This is what happens.

Redirecting to ny3.blynk.cloud:80

And it will never connect.

Seeing the same thing. Using the example code. Got my token from the my account, no joy. Deleted the device, made a new one, updated the token and still same problem. Used both of these lines:

Blynk.begin(auth, ssid, pass);
Blynk.begin(auth, ssid, pass, "blynk-cloud.com", 80);

Hardware is a WEMOS D1 Mini clone. I’m in Taiwan, if that matters.

Ok… ended up creating a new device via the app, and it is now showing up at connected on my account at the website. I used the new token, but I’m getting the same message - “Invalid auth token”

I can create my own thread, if that’ll help de-confuse things…

Ok… last update… Sorry to be spamming this thread…

It seems to work when I use the Blynk.edgent 8266 example file, which does not have a place to enter the token (which apparently has already been added, along with SSID info with wifi provisioning), but other sketches (pre 2.0 maybe?) give me the “auth token” error. Is it possible to enter ssid/pwd/token into a sketch, or do you now have to provision over wifi?

Any other ideas Pete?

Have you tried port 443 ?

Pete.

1 Like

Ok so I tried port 443. And I get this response.

Invalid header type: 21

And then it will retry the connection over and over.

Ok so I tried connecting to 64.225.16.22 and port 80 and so far it is working.