Bluetooth and Blynk App (unable to add any widgets if BT widget is in place)

I am adding the Bluetooth widget(Not BLE) in the blynk app on Android but after adding the widget it does not allow me to add any other widget and says doesn’t work with BLE yet but I am using the normal Bluetooth widget.

I am using Android 8.0

Please find the images attached below.

This is not an error… BT/BLE is a direct link between the App and device, thus no internet/server link on the device as it would have with WiFi. Thus certain widgets that require device to Server link will not work with BT/BLE.

I am unable to add even a button widget

Show that screenshot

The first screenshot is taken after selecting the button widget

Show the Widget Box with the buttons and displays and this supposed error… so far all you have shown is the widgets that require aforementioned Device-Server link

This is the widget box.

Now, I press the button widget, nothing is added and I get this message-

I am using Android 8.0 on Mi A1
I am able to add buttons if I remove the Bluetooth widget

OK, hold yer horses :stuck_out_tongue: I was able to confirm this issue… even on Android 4.4.2

Heads up @BlynkAndroidDev Issue is: Unable to add any widgets if BT widget is already in place, it must be removed first, then added last.

I hope its resolved soon :stuck_out_tongue:
In urgent need of this !

So, try laying out and setting up all your widgets before adding the BT widget and see if it connects and works that way.

Tried that, wasn’t working!
Will try again ASAP


Didn’t connect?

Connected but didn’t respond?

Gave error messages in either case?

Caught on fire?

Connected but the button did not turn on/off a digital pin

Confirm your BT module connections, BAUD rate and pin choices for SoftSerial, if you use that.

Using an UNO & JY-MCU (HC-06), I just tested a button and slider on two LEDs and everything works as it should… but I did need to add the other widgets before adding the BT widget.

A pain for sure, but will allow it to function until the issue is checked & resolved.

The sketch from the example section wasn`t working (github repository).
Now, I tried the sketch builder for bluetooth and it worked!

I am also getting login timeout continuously.

[163721] Connecting...
[165841] Login timeout
[168841] Connecting...
[170961] Login timeout
[173961] Connecting...
[179081] Connecting...
[184201] Connecting...
[189321] Connecting...
[191441] Login timeout
[194441] Connecting...
[196561] Login timeout
[199561] Connecting...
[201681] Login timeout
[204681] Connecting...
[206801] Login timeout
[209801] Connecting...

My sketch is pretty empty:

/* Comment this out to disable prints and save space */
#define BLYNK_PRINT Serial

#include <BlynkSimpleSerialBLE.h>
#include <SoftwareSerial.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "token";

SoftwareSerial SerialBLE(10, 11); // RX, TX

void setup()
  // Debug console

  Blynk.begin(SerialBLE, auth);

void loop()
  // You can inject your own code or combine it with other sketches.
  // Check other examples on how to communicate with Blynk. Remember
  // to avoid delay() function!

You don’t appear to be connecting at all?..

Is your App project active and showing as connected to the device?

Is your screen set to stay on (when it sleeps, so will your connection).

And is the BT module set for 9600 BAUD?

Also confirm you have…

Arduino TX (pin 11) -> BT RX
Arduino RX (pin 10) <- BT TX

This is what I am running on my UNO & JY-MCU (HC-06)

#define BLYNK_PRINT Serial
#include <BlynkSimpleSerialBLE.h>
#include <SoftwareSerial.h>

char auth[] = "b14319618xxxxxxxxxx18d0e75bf571";

SoftwareSerial SerialBLE(2, 3); // RX, TX

void setup()
  Serial.begin(9600);  // Debug via Serial Monitor
  SerialBLE.begin(9600);  // BT modual 
  Serial.println("Waiting for connections...");
  Blynk.begin(SerialBLE, auth);

void loop()


I am able to connect but geting login timeout frequently.

___  __          __

/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
//_, /////_
__/ v0.4.8 on Arduino Uno

[5001] Connecting…
[5166] Ready (ping: 46ms).
[41322] Heartbeat timeout
[46264] Connecting…
[48384] Login timeout
[51384] Connecting…
[53504] Login timeout
[56504] Connecting…
[56624] Ready

Followed by the one above