Autorun blynk on Raspberry Pi

По ссылке:
Дополните инструкцию для Raspberry Pi правильным прописыванием в авто запуск.

Уже второй день бьюсь - куда-бы прописать: sudo blynk-library/linux/blynk --token=YourAuthToken
Все без толку.

try add it to /etc/rc.local, with & at end of string

rc.local in raspibian OS not work

/etc/rc.local then

1 Like

did you manage to autorun blynk on reboot?

same here

please update us here if you figured it out

thank you

till now i managed to get rc.local working manually

but after reboot it doesn’t work.

i added this in the rc.local

./blynk-library/linux/blynk --token=my token &

when i run sudo /etc/init.d/rc.local start

it works. but after reboot it doesn’t work.

Step1: sudo nano /etc/rc.local
Step 2: Add the following line into the file:

/usr/bin/java -jar /home/pi/blynk/server-0.7.4.jar -dataFolder /home/pi/blynk/data &

(Where /blynk is the directory your server file is located)

Step 3: Ctrl+X
Step 4: Y (To save)
Step 5: done

i got it working

add this to rc.local

/home/pi/blynk-library/linux/blynk --token=<your token> &

it doesn’t work for me because there’s an error that say" sintax error “&” unexpected" can anyone help me please

I’m getting a Raspberry Pi 2 also to run a server locally. Is there a step by step manual to do so to complement the instructions posted here?

1-Get the NOOB software onto a SD card;
2-Install Raspbian software
3-Install / update java

Now were to put the server.jar file? In the sd card? Which folder? And should I use a ssh terminal to run the server (putty, lxterminal…)?



Hi, added instruction for rasp PI. Specially for you =). I don’t have rasp at the moment so let me know if it works for you.

1 Like

RESOLVED(auto start blynk on raspberry pi):

-type this in terminal sudo nano /etc/rc.local

  • add: ./blynk-library/linux/blynk --token=my token & after: fi

  • thats it, try it with sudo /etc/rc.local start

Create one new file in pi and add the command “sudo ./blynk --token= mytoken” as its contents. Then make it executable by using command “chmod 755 filename”. Finally open bashrc using command “sudo nano .bashrc” and go to last and add “./filename” where filename is the newly created executable file. Its working for me. Hope it works for you as well.

Could you do it like this?
sudo nano superscript
then save it: Ctrl + X, Y, Enter

Open the .bashrc
sudo nano .bashrc

Scroll down to the bottom and put:
Then save it: Ctrl + X, Y, Enter
And you’re done!
You can also use blynkstartup or other names instead of “superscript”
There also can be some permission issues, I solved it with this.
Hope it’s gonna work for ya!

Users responding to questions on very old topic; Closing.