BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Aruino UNO Simcom808


#1

Hi guys i use an Arduino Uno with a SIMCOM808 shield. I tried to run the SIM800_900 Example. It is working till the connection to the blynk server.
The following information is showing.
I tried different ports. Any ideas what to do ?

Initializing modem…
[3521]
___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
/
//_, /////_
/
__/ v0.5.4 on Arduino Uno

[3614] Modem init…
[3884] Connecting to network…
[3966] Network: D1
[3966] Connecting to internet.t-d1.de
[8940] Connected to GPRS
[9007] Connecting to blynk-cloud.com:8080
[9962] Ready (ping: 304ms).
[15011] Connecting to blynk-cloud.com:8080
[16045] Ready (ping: 279ms).


#2

Any (properly formatted :wink: @Gunner) sourced code you could provide?
I would expect to see something like …

Connecting to blynk-cloud.com:80

instead of

Connecting to blynk-cloud.com:8080

in the log output.


#3

8080 is still valid hardware port for Cloud… and those logs do show connection with that port… but yes, we need to see the rest of the code in-order to guess further :stuck_out_tongue_winking_eye:


#4

@Gunner: “server.properties” file of server-0.40.2 looks like this:

...
#http, plain web sockets and plain hardware port
http.port=8080

#if this property is true csv download url will use port 80 and will ignore http.port
force.port.80.for.csv=false

#if this property is true redirect_command will use 80 port and will ignore http.port
force.port.80.for.redirect=true
...

If this also runs on the cloud server then port 8080 is NOT an option anymore.

“Connecting to …” does not mean “Connected to …” from my perspective …


#5

I know all that… I use both :wink:

Adding in a port option is NOT required when connecting to the cloud asthe library assumes the proper port… but manually inserting port 80 or 8080 will work just the same… basically a non issue here.

But the following line does mean connected :stuck_out_tongue_winking_eye: So something else is causing re-connection. Just have to wait for the OP to provide more input :robot:


#6

If I can ping a server (ICMP) it does not mean that I can also connect at the application level …


#7

Dude… stop confusing the newbies :stuck_out_tongue_winking_eye: … the library provides that last statement once it is connected to the server… the key work there is CONNECTED… thus we know that much at least is working… just not for long.


#8

I only see “Connected to GPRS” and “Connecting to blynk-cloud.com:8080”.
How can that mean it’s working ?


#9

@IBK As for the OP, It connected then 5 seconds later disconnected & reconnected, or more likely disconnected right away but took 5 seconds to reconnect… who knows from there… not enough info… probably something with the connection method (the Cellular link) is causing the issues.