Arduino UNO not connect with Blyink via USB

I´m trying to connect my Arduino with Blynk via USB, I did all the steps, running the script, try others USB ports and read all the topics here and Blynk still showing me the message “Your device is offline”.
I really don´t know what could be wrong.

Sorry Dmitriy, I simple can´t find what I´m doing wrong… :worried:

I used the same sketch of the video, and it print in terminal:
“Blynk v0.4.6: Device started
Type ‘Marco’ and get a reply, or type anything else and get it printed back.”

So it stops.

@Pinhal It looks like you are connecting ok, and you say you get a response back from terminal… but what do you mean “So it stops”?

If you still need assistance, can you open a new Topic for this and we can go more indepth with troubleshooting. Thank you.

Yes, it seems like it´s start to communicate and them stop.´
I´ll try to solve and if not find an answer I´ll open a Topic.
Thanks a lot.

Sound good. Also make sure you follow this instruction… anything trying to send data over “Serial” will cause communication issues. As per the example sketch, Use “SwSerial” instead for any serial prints. (with use of a TTL-USB adapter).

  // Do not read or write this Serial manually in your sketch

Hello again @Pinhal. I have moved your relevant posts to this new topic. (EDIT - I goofed and moved them in two sections; they are now out of order… carry on from here --> Arduino UNO not connect with Blyink via USB )

Let’s start wil confirming if you are getting connected and able to briefly use terminal before it stops, as you stated before, but then said different in this new topic’s opening post… or are you now not connecting and not able to use terminal at all?

Hi. I did this tutorial and Blynk still saying that my device is offline.
Someone could help me, please?

@Pinhal please provide more info. What steps did you make. what sketch do you have? Did you put token? Did you run script?

@Dmitriy I did everything as Ann said. The same instructions, I got the same sketch she used, I put the token and run the script. My OS is Windows and she used Mac in the video, is there anything diferente I should do?
Thanks a lot :slight_smile:

What script did you run? What output do you see?

I run blynk-ser.bat

The out put was:

Connecting device at COM3 to
OpenC0C("\.\COM3", baud=9600, data=8, parity=no, stop=1) - OK
Connect(“”, “8442”) - OK

Blynk port could be blocked on your router. Please check them first -

@Pinhal Opps, I goofed a bit in moving the posts over here… so they are now out of order :stuck_out_tongue:

Just carry on from here by answering my last question…

OK let´s see we can solve this :relaxed:
Well, I tested some sketches from the exemples files, so when I tested the one showed in the video for sometimes and it shows in the terminal like this:

"Blynk v0.4.6: Device started
Type ‘Marco’ and get a reply, or type anything else and get it printed back.

Then appears the message “Your device is offline” as I said.
And all others sketches show this message on the Blynk app.

I hope I was clear, English is not my native language and sometimes I don´t know if I´m doing myself clear

Thanks a lot for your attention.

Do you get response when you type something terminal?

No @Dmitriy. there´s no response, just the message saying my device is offline.

OK, you are connecting OK, based on one of your above posts, and the terminal sketch seems to work briefly… have you tried any of the other sketches in the Sketch Builder - Link in the upper right corner of this page.

Also, be aware that after you run the blynk-ser.bat file, you MUST keep that DOS window open in order to maintain the connection to the server. You can minimize it, but if you close it, the connection is gone.

Also, you cannot use any Serial print statements in you script (you can use soft serial on the UNO) And even using the IDE monitor on the same COM port, while the USB link is running, will not work.

1 Like

OK it´s work. I can´t believe it. :grinning: :confetti_ball: :tada:
I was closing the DOS window when run the script, that´s the problem. Now it´s working and I will testing another sketches and try to make some cool projects with Blynk.

Thank you @Gunner, thank you @Dmitriy, thank you guys.

1 Like


1 Like