Arduino Uno is Offline - Connecting via USB

So I followed all the steps, I downloaded the libraries, opened the serial_usb example, I got the auth token, I created a new project, created a button, I ran the required lines in the command prompt. Once i had done all the introductory steps I i connected an led into digital pin 13, i attempt to click it on using the button i created in the blynk app but it just keep saying “Arduino Uno Offline” - (Attempting to connect via USB) Anyone else had this problem or now how to solve this problem. Thanks

Did you run script? Please show output on console after running script.

Yeah when I ran the script it uploaded to the board with out any errors. It just said how many bytes the sketch used ect. There was no error messages

But i do get output to my serial monitor! My auth token prints out to my serial monitor

@leahfanning Please read instruction in USB sketch comments carefully. You need to run separate script (.bat or .sh).

yeah sorry I thought you were talking about running the script in arduino. In the command portal I ran a .bat script

I first ran " cd C:\Users\lfanning\Documents\Arduino\libraries\blynk-library-0.3.1\scripts"

and then I ran “blynk-ser.bat -c COM4” – because my arduino uno is connected in COM4

and pressed enter three times

Ok. So what is the output afre you run above? Could you please make screen shot?

Ok so it said that serial port COM4 was not found. On my arduino sketch screen though it says on the very bottom right “Arduino/Genuino Uno on COM4”

did you turn off the serial console in the Arduino IDE? You can’t use the com port in multiple programs

I think I turned it off but it still didnt work how exactly do you turn it off?

Just by closing the window of the Serial monitor, that’s enough.

Ow yes, have you turned off your firewall by the way?

Do you need to have it turned off?

It will probably help yes, unless you allow the outgoing Blynk port (8442 for hardware I believe).

I have never had to do anything with my firewall when using USB.

yeah i dont really want to disable my fire wall.

This is what I keep getting when i try to run “blynk-ser.bat -c COM4” in cmd.exe do you know what this means?

Thanks for your help so far guys

Despite what I said, 10060 error often relates to firewall issues. So try disabling for a test.

Is that the only way to fix it because I dont have access on my computer to disable firewall

If you don’t have access to the firewall then maybe your ‘administrator’ is blocking access to some ports.

Do you use any proxies?

As per my earlier post the only firewall reference I have ever seen relates to the Arduino IDE itself and I have never had to disable the firewall or open any specific ports to access Blynk via USB.

Do you remember being asked about firewall access when you installed the Arduino IDE?

The hardware just wants to connect to on a non-default port. Because of that in the majority of cases it will be blocked by a firewall.