Arduino uno + Ethernet2 can't connect

I want to connect to Blink using Arduino uno + ethernet shield2.
In the program below
[138] Connecting to
becomes. please help me

#define BLYNK_TEMPLATE_ID " *** "
#define BLYNK_DEVICE_NAME " *** "
#define BLYNK_AUTH_TOKEN " *** "

#define BLYNK_PRINT Serial

#include <SPI.h>
#include <Ethernet2.h>
#include <BlynkSimpleEthernet2.h>

char auth[] = BLYNK_AUTH_TOKEN;

byte arduino_mac[] = { 0x**, 0x**, 0x**, 0x**, 0x**, 0x** };
IPAddress arduino_ip ( 172,   **,   **,  **);
IPAddress dns_ip     (  *,   *,   *,   *);
IPAddress gateway_ip ( ***,   **,  *,   ***);
IPAddress subnet_mask(***, ***, *,   *);

void setup(){
  Blynk.begin(auth,"", 80,arduino_ip, dns_ip, gateway_ip, subnet_mask, arduino_mac);

void loop()

Please edit your post, and add triple backticks ``` before and after your whole sketch.

@seigikosa You might have edited your post, but you’ve not used the correct triple backtick characters, despite @John93 kindly providing some for you to copy/paste.

Please edit your post again, and this time use the correct characters.


Have you tried



Blynk.begin(auth, "", 80);

Instead ?

Do you have the latest version of the blynk library (1.1.0) installed ?

What do you see in your serial monitor?

(Copy/paste the serial monitor text, and use triple backticks in the same way as when you post code. Do not post a screenshot of your serial monitor output).


is installed

Hiding your internal IP addressees, DNS server address, MAC address etc doesn’t really help.
My guess is that you’re doing something wrong there, but you’d also need to provide info about the internal IP address of your router and it’s subnet mask to make any sense of the settings you are using.

Have you tried @John93’s suggestion of not specifying these parameters and allowing them to be supplied by DHCP?


I think there is no problem because it is the IP used in the old Blink.
I was able to connect when I was using it with the old Blynk

Neither of your last thee posts provided any useful information, or addressed the comments or answered the question I asked in my previous post in this topic.

I’ll refrain from commenting further until you provide more useable information.


What is the IP address of your router?

Do you have an internal DNS server running on ?

What IP address does your serial monitor show has been allocated to your device?