BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Arduino uno & ethernet shield W5100 (wasnt online yet)

hi;

i am using arduino uno & W5100 ethernet shield. on my android phone in BLYNK, say WASNT ONLINE YET.
i tried USB and ethernet, but i didnt succeed

please help me

image

It’s possible that your ISP is blocking the Blynk trafic.
Try connecting to a friend’s network and see if that solves the problem.

Pete.

Thanks for answer, i tried at home and succeed but my project has ofline yet. What can i do this problem?

What exactly does “succeeded” mean?
If the device is offline then it won’t respond to commands from the Blynk app or upload any data to the app - if that’s what’s happening then it doesn’t sound like success to me.

Pete.

I want to say, my arduino isnt write (wasnt online yet) on my phone any more. But now writes (offline since at xx). As a result, i dont control to led with BLYNK app. Sometimes i see online, after it iş go offline.
When i turn it off, after on, Blynk is online with arduino. But after a few minute, it write offline

Why does it fall to offline. What can i do this problem ??

At the moment, we’re having problems understanding where you are with this issue.
The issue could be with your ISP, and I suggested that you try a friends network - but I have no idea if you tried this and what the outcome was.

It could be a problem with your code, but without seeing your code it’s difficult to say.

Pete.

Hi Pete,
My blynk project code, in your sample code. So in my blynk app writes first online, a few minute later write offline.

That obviously makes things crystal clear :rofl:

Pete.

My button is D13, output. When i was push to button, in arduino led is not light. What i do to wrong :slightly_smiling_face:

Pete.

My arduino has online, 3 hours yet. I dont understand this :). I will send my code to you, tomorrow

hi Pete;
my code is :

[Unformatted code removed by moderator]

Do you think it works ??

İSTENEN SICAKLIK = set value
sicaklik = room temprature
voltaj_deger = incoming volts from LM35
gelen_veri = incoming value from LM35
role = output of relay

@Metin_Tataroglu please edit your post and add triple backticks at the beginning and end of your code so that it displays correctly.
Triple backticks look like this:
```

Pete.

Hi, my code is this;

#define BLYNK_PRINT Serial
#include <SPI.h>
#include <Ethernet.h>
#include <BlynkSimpleEthernet.h>
//#include <SimpleTimer.h>
#define W5100_CS  10
#define SDCARD_CS 4
#define SET_TEMP V5
#define EXTERNAL_CONTROL V1
char auth[] = "***";
float VOLTAGE = 0;
float TEMPERATURE = 0;
int INCOMING_DATA = 0 ;
const int RELAY = 9;
const int LM35 = A0;
bool d=1; 

BlynkTimer timer;

BLYNK_READ(SET_TEMP)
{
  // This command writes Arduino's uptime in seconds to Virtual Pin (5)
  Blynk.virtualWrite(SET_TEMP, millis() / 1000);
}

BLYNK_READ(EXTERNAL_CONTROL)
{
  // This command writes Arduino's uptime in seconds to Virtual Pin (1)
  Blynk.virtualWrite(EXTERNAL_CONTROL, millis() / 1000);
}

void setup()
{
  pinMode (RELAY, OUTPUT);
  Serial.begin(9600);
  pinMode(SDCARD_CS, OUTPUT);
  digitalWrite(SDCARD_CS, HIGH); // Deselect the SD card
  Blynk.begin(auth);
  timer.setInterval(1000L, sendUptime);
}

void sendUptime()
{
  Blynk.virtualWrite(V10, TEMPERATURE);
  Blynk.virtualWrite(V9, millis() / 1000);
}

void loop()
{
  Blynk.run();
  timer.run();

INCOMING_DATA = analogRead(LM35);
VOLTAGE = (INCOMING_DATA / 1023.0) * 5000;
TEMPERATURE = VOLTAGE / 10.0;

 if
  ((V10 <= ( V5 + 2 )) || (V1 == "1"))
  {
    digitalWrite (RELAY, HIGH);
  }
  if
  ((V10 > ( V5 + 2 )) || (V1 == "0"))
  {
    digitalWrite (RELAY, LOW);
  }


else { 
  if(V10 - 3 < V5 && V5 > V10 + 3)
  {
    digitalWrite (RELAY, LOW);
  }
  }
}

But it didnt worked.
My role (9,output) dont high…

@Metin_Tataroglu you’ve used the wrong type of characters, despite me giving you some triple backticks to copy and paste.

Please EDIT (using the pencil icon at the bottom) one of your previous posts and insert the code with the proper backtick characters.

Pete.

hi @PeteKnight ,
i rearrenged my code between backtick

the boiler will work until it rises 2 degrees above the set temperature.
wont work 2 degrees under above the set temperature

Mr @PeteKnight hi,
What can i do for my this project, please help me.
I want to be run in my home…