Arduino UNO and ESP8266 not accessible from app

Hi, hope someone can assist, I’ve been struggling for quite a while and just cannot find the problem or what I’m missing.

The serial output I get:
[19] Blynk v0.3.2-beta
[520] Connecting to KogmanKeisie
[3741] IP: +CIFSR:STAIP,“”

[3790] Connected to WiFi
…then nothing else

Hereafter I go to the app and try to connect but I only get the message “Arduino UNO is offline” all the time.
I checked and I can succesfully ping to the ESP on our network so it’s definitely successfully connected.

Any ideas?

Kind Regards,


Try with different Blynk library, not BETA?

Put your code maybe there is a problem with that?

Is there a spot in your code to connect you to the Blynk server?

Here is the code, I’m using the Blynk ESP8266 Shield via Software Serial example (took out my SSID, password and Blynk auth):

//#define BLYNK_DEBUG
#define BLYNK_PRINT Serial    // Comment this out to disable prints and save space
#include <ESP8266_SoftSer.h>
#include <BlynkSimpleShieldEsp8266_SoftSer.h>

// Set ESP8266 Serial object
#include <SoftwareSerial.h>
SoftwareSerial EspSerial(2, 3); // RX, TX

ESP8266 wifi(EspSerial);

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "***";

void setup()
  // Set console baud rate
  // Set ESP8266 baud rate
  // 9600 is recommended for Software Serial

  Blynk.begin(auth, wifi, "***", "***");

void loop()

I have Blynk library v0.3.1. Should I try another version?

Not sure, I’m new to Blynk. Please see code I posted.

Have you set your ESP to 9600 baud? I know Blynk says it’s connected to the wifi, but it may be something to check by directly attaching the ESP to a serial port. Mind the voltage though!

Yes I have latest firmware and ESP is set to 9600 baud.
Tested with ESP connected to serial with AT commands.
I use an external 3.3V power supply.

Do you have exactly the same auth code in code and Blynk APP.

I think you checked it many times but I need to ask anyway.

Yes, it just take 1 minute to test, so why not test with 0.3.1

I was also wondering, do I need to forward specific ports on my router for Blynk to be able to communicate with the ESP? In this case, which ports and what protocol?

Do you use a Blynk Cloud or Local Server?

See this topic for Port

Using the Blynk cloud. Will it be necessary to forward port 8443, 8442. 8441 on my adsl router if I just want to connect app to ESP connected to internet via our wifi?
I’ve tried 0.3.1 and 0.3.0, no difference in results.

Latest serial result:

[19] Blynk v0.3.2-beta
[520] Connecting to KogmanKeisie
[3748] IP: +CIFSR:STAIP,“”

[3798] Connected to WiFi

I can successfully ping from my pc to (the ESP ip)

When I try to connect from app I still get “Arduino UNO is offline”…

Just to confirm connections between ESP and UNO:
ESP Rx - UNO Tx (D3)
ESP Tx - UNO Rx (D2)
and then also
ESP VCC & CH_PD - 3.3V external 700mA power supply
ESP GND - external power supply GND
not connected on ESP:
GPIO 0, GPIO 2 and RST

ESP red led on
ESP blue led flickers now and then

Baud rate 9600 is set on ESP and I did test with AT commands

Running out of ideas…
Is their any other way to test?
Perhaps a sketch that someone can share?

You don’t need to forward ports because it’s all about out going connections. Port forwarding has to do with incoming connections.

What you can do is reset your modem/router/accesspoints. That helped me in some cases. It may be worth trying.

I also have been used arduino UNO and ESP8266 module with Blynk app about one month.

Suddenly, WiFi connection is disconnected.

I tried to change Blynk library and recreate Blynk app project. So, WiFi is reconnected

But WiFi connection is disconnected after 3 weeks.

I tried to reconnect many times. But I can not reconnect to Blynk server until now.

I wonder if anyone else is also having this problem…?

Why don’t you use the hardserial instead of softserial for the ESP. You can use the softserial for the comms with your pc over an FDDI adapter.

Hi. I have the same problem. Have you figured out a solution yet?