BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Arduino IDE compile Error "ESP8266_lib.h" NOT FOUND

I am running an Duinotech Arduino 2560 board with built in wifi via the ESP8266 chip.

I have tried to compile the Blink LED example available from the Blynk Website.
The error is “ESP8266_Lib.h: No such file or directory”
The error is correct as the file does not exist, I have checked my libraries.
I have updated the libraries as per Blynk Website recommendation, http://help.blynk.cc/en/articles/512105-how-to-install-blynk-library-for-arduino-ide.

I have tried two ways of updating the library, that is via the library manager and via zip file.
How do I install this library file when I dont know where to find it.

If you look at the manual installation instructions, it explains when the final structure of your library folder should look like for the Blynk libraries:

your_sketchbook_folder/libraries/Blynk
your_sketchbook_folder/libraries/BlynkESP8266_Lib

If youre using a standard Windows installation for the IDE then this will be:

Documents/Arduino/libraries/Blynk
Documents/Arduino/libraries/BlynkESP8266_Lib

The necessary files are in the Zip file:
image

Pete.

Thanks for your help Peter, I have not tried it yet, but it should work.

I just downloaded the zip file from GitHub - blynkkk/blynk-library: Blynk library for embedded hardware. Works with Arduino, ESP8266, Raspberry Pi, Intel Edison/Galileo, LinkIt ONE, Particle Core/Photon, Energia, ARM mbed, etc. and although it has the same version number, the structure is completely different and BlynkESP8266_Lib does not exist. This is April 01, 2021.

I’ve just followed your link, downloaded version 0.6.1 of the library, opened the .zip file and it’s right there…

And this is the contents of the BlynkESP8266_Lib folder…

What version of the library did you download?

Pete.