Arduino Can't Compile Blynk Sketch says WiFi not declared

I have had 3 working Blynk Sketches I used Arduino to upload code. All have worked great then all the sudden tonight I can not compile. I get an error stating WiFi is not declared in scope on the ConfigMode.H tab. I have noticed if I remove the ssl from #include <BlynkSimpleEsp32_SSL.h> on the BlynkEdgent.H tab it can compile and upload but does not let me add the device to blynk and no wifi hotspot is created. I tried just doing a new sketch using the stock blynk example sketch and adding my template ID and Template name with no luck.

When you post compiler error messages it’s far better if you copy/paste the text and use triple backticks at the beginning and end rather than posting a screenshot.

What happens if you change your ESP32 core from v3.0.0-RC1 to v2.0.14 ?

Pete.

1 Like

Roger that, I will make sure to do that. I thought screenshot would be better for this. Thanks for the tip.

As for the core version. You were spot on there. I moved back to v2.0.14 and it worked but was missing the ESP32 C6 boards. I moved back to 3.0.0 alpha not RC1 and that has the C6 board and still worked on compiling. Really appreciate the help.