Application Offline - all ports forwarded

I have been running Blynk Server on a RPi3 for a few months. just recently (start of this month) i have noted that the “Application is Offline”

I can still log in to my server and authenticate properly.
I can still see the webcam feed in the application (this is an rst feed so its not directly related to blynk but does confirm communication path between endpoint and device)
i can not interact with the application, every button i push i get the application is offline.

I am running the java8 package and specifically version 0.36.1. I have also tried 0.33.2 and my original setup on 0.33.1. all of which dont work.

To confirm port forwarding, this is a screenshot of my port forward
To confirm the port listening on the Pi this is a screenshot of tcp ports listening.

Any help to let the application become online would be greatly appreciated.

Check your Blynk logs

Reading through your post again, I think we need more details…

By “Application Offline” do you mean the Blynk App is not logging in? Or the device in a particular project is not online?

If referring to the project, is it also running on the same RPI?

If so, what library (C++, NodeJS, Python)?

Do you have ANY projects that work?

Have you switched all clients over to port 8080 as required for Local Server now?
Read this for more info - New Blynk Library v0.5.1 is Released (important for local server owners)

@Dave_Reid hello. Latest server version now uses port 8080 for hardware on the local server. So you have to either do port forwarding 8442 > 8080 or change default 8080 port to 8442 on the local server setting or change port within your skethc in order to make it work.

Or change BlynkConfig.h :wink:

1 Like

Thanks Gunner - on ios, when launching the blynk app, i only have 1 blynkapp which is my garage door opener. it lauches to that, and it says its offline.

i do not have any other projects setup however i did do a test project to test and it was also offline.

I will look at moving over to port 8080, not sure exactly how to set that up though.

as per other reply here is my blynk.log

pi@pi2:~/blynk/logs $ cat blynk.log 
22:10:26.126 INFO - Using data dir '/home/pi/blynk'
22:10:29.470 INFO - Region : local. Host :
22:10:31.996 INFO - Initializing gmail smtp mail transport. Username : SMTP host :
22:10:32.136 INFO - Didn't find custom user certificates.
22:10:32.144 INFO - Didn't find Let's Encrypt certificates.
22:10:32.145 WARN - You didn't specified '' or '' properties in file. Automatic certificate generation is turned off. Please specify above properties for automatic certificates retrieval.
22:10:32.145 WARN - ATTENTION. Server certificate paths (cert : '/home/pi/blynk', key : '/home/pi/blynk') not valid. Using embedded server certs and one way ssl. This is not secure. Please replace it with your own certs.
22:10:35.610 INFO - Hardware SSL server listening at 8441 port.
22:10:35.617 INFO - HTTP API and WebSockets server listening at 8080 port.
22:10:35.620 INFO - HTTPS API, WebSockets and Admin page server listening at 9443 port.
22:10:35.626 INFO - Mqtt hardware server listening at 8440 port.

just confirming too that adding a NAT rule for internetIP:8080 to internalIP:8080 didnt work as per the 3rd last line in the log file.

Thanks Dmitriy, i tried setting up 2 forward rules:

  1. making a internetIP:8080 -> internalIP:8080 (this didnt work)
  2. making a internetIP:8442 -> internalIP:8080 (this didnt work too)

i do not have a sketch, i made the app / interface completely within the Blynk IOS app (drag and drop).

Hold on to your hats. Question: is the Phone connected to the same network as the Pi Server? If so, it probably has nothing to do with port forwarding…

no, i use this outside of my network. fair question though as yes, port forwarding wouldnt matter :slight_smile:

Have you tried rebooting the router? Sometimes the NAT table will fill up and doesn’t get emptied anymore.

Hey thanks for the continued support, but yes i have.

not sure if it makes a difference but it does continue to point to the stand alone server, even when connecting locally, the app is offline.

so removing port forwarding out of the picture hasnt helped so it is something to do with the way the server is listening to requests.

guess if we cant resolve it i will have to go back to a standard website unfortunately.