BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

App stopped responding


#1

Hello everyone,
For some reason, yesterday afternoon my blynk app stopped responding - constant loading of the control screen.
I tried uninstalling and clear data in order to re-login to my account but now I am stuck on logging in screen saying “connecting” and that’s it.
Anyone else having the same issue?

Thanks


#2

What server, Cloud or Local?

If Cloud, is your internet connection on the phone good? Can you ping blynk-cloud.com from the phone? Perhaps your ISP / cell carrier is blocking something

If Local, is it on?.. Did you update it to latest version? Confirm correct custom IP (to your Local Server - may require port forwarding if you are doing so from outside your network) & port (should be 9443) in your App


#3

I use cloud server. I have tried pinging from my laptop and android. both timeout.

ping blynk-cloud.com
Pinging blynk-cloud.com [188.166.206.43] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

I have checked online and that IP Address is actually responding.
I tried through both ISP and mobile data. That is really really weird…


#4

Sounds like something (ports?) being blocked in your region or ISP. That is something you will need to check on your side.


#5

How would I know what is being blocked exactly?
And my entire smart house is down for now ??? :frowning:


#6

I guess you call whomever handles your phone and or home internet and ask? Give them the Blynk URL/IP and the ports used, typically 80, 8080, 443, 9443.


#7

When you say:

What exactly do you mean?

Pete.


#8

Probably something like https://downforeveryoneorjustme.com/


#9

I have used https://ping.eu/ping to ping that IP Address


#10

So that means it is probably a port block in your region, as that shouldn’t affect Ping, but will of course block whatever affected ports.


#11

A weird thing that going to blynk-cloud.com on my browser redirects me to blynk.cc just fine.


#12

Not weird… that is a basic internet port 80, whereas I believe the App uses SSL (443, 9443)

Do your devices connect fine to Blynk’s Cloud server?

Using IDE serial monitor and…
#define BLYNK_PRINT Serial // This prints to Serial Monitor


#13

I will check that out when I get back home.
I managed to get the app starting with one out of three mobile providers and zero out of 4 ISPs.
After talking with the ISP over the phone they said that the problem is with the server - something with DNS providers. They said they have encountered the same problem with a bank website in the UK a few weeks ago and the customer talked with the bank to sort it out.
Any chance that this is actually a problem with blynk servers?


#14

@Dmitriy ?


#15

I am trying various traceroute methods and I can see that the connection get interrupted in DigitalOcean servers in germany.
Our local IoT community is now starting to post on facebook regarding this issue (I am not the only one)


#16

I guess just wait it out.


#17

Meaning for Dmitriy to answer or for the problem to solve itself?


#18

Either / Both :stuck_out_tongue_winking_eye:

If it is some DNS issue, I suppose you could try setting the App to Custom and using that IP you got in the Ping. Leave the Port as 9443


#19

You were right… all good now for some reason


#20

Sorry im not catching this til now. On Feb 1, they changed the way dns worked across the internet. Udp dns was supposed to be shutdown, so only Tcp was used. I heard reports there were a few places that took a hit, but it was well publicized, so all providers were supposed to know about it.