App reconnects to main server all the time, becomes unuseable


I just started with Blynk again after some weeks, my app and esp2866 server still worked fine. Then I noticed the updates to the app, and just updated from the Play Store. Now the app displays “reconnecting to server” all the time, about every second. I becomes pretty much unusable because of that. This is already in the main screen where all the projects are displayed, it has nothing to do with a specific project.

Why is it disconnecting/reconnecting to the Blynk server all the time? This is on a Galaxy S3. Is there a way to downgrade the app so it works again?

Hello. Please try to logout and login again. Does that help? Also what is your account?

Hi Dmitry,

I just found the error, I had actually setup a local server and forgot about that. :blush: I updated the server, and now I hope it works. Sorry!

However I just tried to use the admin website to change the password for the user on my local server, and I think there may be a real bug there. I changed the password and then clicked ‘save’ at the bottom of the page, but I get a message ‘Oops, an error occured : (code: -1) null’. The log contains the following:

14:28:05.302 ERROR - DecoderException. io.netty.handler.codec.DecoderException: java.lang.NullPointerException at io.netty.handler.codec.ByteToMessageDecoder.callDecode( at io.netty.handler.codec.ByteToMessageDecoder.channelRead( at at at at$ at at at at at io.netty.util.concurrent.SingleThreadEventExecutor$ at io.netty.util.concurrent.DefaultThreadFactory$ at Caused by: java.lang.NullPointerException at java.lang.System.arraycopy(Native Method) at com.sun.crypto.provider.GCTR.reset( at com.sun.crypto.provider.GCTR.doFinal( at com.sun.crypto.provider.GaloisCounterMode.doLastBlock( at com.sun.crypto.provider.GaloisCounterMode.decryptFinal( at com.sun.crypto.provider.CipherCore.finalNoPadding( at com.sun.crypto.provider.CipherCore.doFinal( at com.sun.crypto.provider.AESCipher.engineDoFinal( at javax.crypto.CipherSpi.bufferCrypt( at javax.crypto.CipherSpi.engineDoFinal( at javax.crypto.Cipher.doFinal( at at at at at at at io.netty.handler.ssl.SslHandler.unwrap( at io.netty.handler.ssl.SslHandler.unwrap( at io.netty.handler.ssl.SslHandler.decode( at io.netty.handler.codec.ByteToMessageDecoder.callDecode( ... 12 more

Hm… Is that 0.15.3? Could you please give me full log file ( What operating system do you use for server?