BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

API Request Invalid token

Hi Guys!

I am facing an issue with my API call

Using Postman to test my API requests

When I make a GET request to get the pin value of V0 or V1, I receive the message as Invalid Token.

My request look like this-

 GET http://188.166.206.43/{auth token}/get/V1`

Response: Invalid Token

In addition to this, I also tried adding port numbers 80 and 8080. Still no luck!

Please help me out here.

Are you using the new blynk or the old one ?

New Blynk.

My devie is not powered on.

Although I have created and configured the device on blynk.cloud.

I created a dashboard and connected and assigned V0, V1 and V2 to some of my widgets. Screenshot below–

I only want to get the current value of my widgets, like gauge value… May be update a couple of slider values as well.

Check this out
https://docs.blynk.io/en/blynk.cloud/https-api-overview

Okay. But I am using the restful api

https://blynkapi.docs.apiary.io

I don’t want to use HTTP api

The api you’re using belongs to the old blynk and it’s not gonna work with the new blynk

for example, if you would like to get virtual pin 1 value, then your api will look like this sample

https://blynk.cloud/external/api/get?token=Rps15JICmtRVbFyS_95houlLbm6xIQ2L&v1

If that doesn’t work all you have to do is put server address with suffix manually depending on your region
More details here
https://docs.blynk.io/en/blynk.cloud/troubleshooting

Oh! The Apiary is the old API? This one - https://blynkapi.docs.apiary.io

Is it?

Yes, it for the old blynk
Now it’s different, Check the link in post number 5

I got it working. Thankyou so much John

1 Like

@Dmitriy could you please kill Apiary link to avoid further confusion? Or add a comment there to check Blynk version.