Any different option/setting to choose between ESP12E and NodeMcu

Corrected Now


But my question is the same program was working fine few months back and even now those devices are online. But why now now ? Has Blynk made any changes in the Lib ? or any changes in the ESP core ??

maybe ESP core…
you have an old version
try 2.5.0 beta 3, but don’t use 2.5.0 final version, it’s buggy 99% :smile:
anyway, you don’t need to test button every 100 ms that makes no sens.
and don’t try to reconnect every 10 sec, because of DHCP issues
BTW, it’s just my opinion :wink:

@Blynk_Coeur @PeteKnight
This is the reason i am using 2.4.2

1 Like

I’m using 2.5.0 beta3 with 2 nodeMCU since a few months.
it looks stable.
but @PeteKnight is right too .

ok i will install the same core and update you shortly !

1 Like

GPIO 7 and 8 are special reserved pins that shouldn’t be used.
See this topic:


1 Like

Tried this out. But no luck. It connects only after like 2 or 3 min . And works way too slow. While the app is showing online the and when i press the virtual button on the app the hardware does not react. I have an LED to check if it works. But it will take 20 sec to react. And goes offline after 1min.

Even with GPIO 4 and 5 … The problem still persists !!
I feel something is wrong in the software side…

weird ! :fearful:
do you have a nodemcu v3?

This is what i am using right now.

I’ll try your sketch, but GPIO7 and 8 doesn’t exist on nodemcu!
I’ll use GPIO2 for the onboard led and GPIO5 for the physical button

Okay ! Now let’s forget the GPIO . I just uploaded the basic Blynk Blink sketch ! Even this is not coming online. I tried the core that you said but no luck . So i reverted back to 2.4.2 .

Should i reset the server ? Actually i have a separate set of local server using rpi zero with a dlink router. When i try to connect on this , some how it connects. Now i am confused !! Even the connection seems to be stable.

I strongly feel that the router is throwing off the connection with ESP12E , and this is causing all the problems. But while saying this i also remember there are 2 NODEMCU running on the same router that is giving problems with the ESP12E!!! I am totally confused.

What do you guys suggest me to do now ?

1 Like

You’re unlucky.
I think your nodemcu has a default.
I have the same issue with one of my nodemcu.
try to connect …
reconnect within 30 seconds …
heart beat time out
rst cause …
and so on…
but what I don’t understand, this nodemcu works fine with a simple demo WiFi sketch, even http server example sketch!
as nodemcu cost is less than 3$, I don’t care about that. :joy:

Sorry if this had been discussed already, but… Can you rule out the MAC/IP address conflict?


Its not about money. Its all about connection and how stable it is.

1 Like

Sorry !! I did not get what you are trying to say. Can you please explain me a bit on this, or give a link that i can look into ?? Thank you in advance.

Obviously each device on your network needs a unique IP address. As your code isn’t specifying a static IP then it should be your router that’s assigning IP addresses via DHCP and these will always be unique - provided you only have one DHCP server on your network (more on that later…).

MAC addresses are hard-coded the hardware of most devices, but on Arduino Ethernet shields you have to specify the MAC address yourself. All MAC addresses on your network must be unique.
You can use a tool like this to scan your network and check IP addresses and MAC addresses, although duplicates won’t be shown:

From what you’ve said, you have multiple routers available and this could be the cause of your problem. If you have two routers acting as DHCP servers on the same network subnet then you have to be very careful that the pool of addresses that you’re allowing them to use don’t overlap.

I’d suggest that you strip everything back to a bare minimum. One router, as many devices as possible disconnected/turned off, use the Blynk cloud server to eliminate local server issues and see what happens.


1 Like

I think my problem is different .

NodeMCU is connected to wifi but never reach blynk server, I use ARP -a cmd to verify.



Can you please give any of your core that i can try here ? If its a personal project then its fine do not share…But it would be help full if you do share. And also please tell me the CORE you are using.

2.5.0 beta3