BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Any different option/setting to choose between ESP12E and NodeMcu

#1

Hello ,

I Purchased a couple of ESP12E modules a few days ago. I flashed the same code that was running absolutely fine on NODEMCU. But as i got my new ESP12E i flashed the same code on to it, but it never connects to the server. I feel its not at all connected to the WiFi also… but in the serial monitor it shows the Blynk on nodemcu logo with the version and says reconnecting server in 30sec… but never connects.

Is this something to so with the firmware of the NODEMCU ? I believe the firmware will wash out once we burn our code into it. Correct me if i am wrong.

Or should i select ESP-01 during the device selection for auth token ?

But what i have experienced is the NODEMCU’s are better when compared to the standalone ESP12E… even though the NODEMCU uses the same chip.

I tried with the local as well as the cloud servers( auth tokens are taken care accordingly) but never connects.

Or is it something to do with my router ? Like is it not assigning ip’s for the ESP’s ? I am confused right now what may be the problem, i tried all the ways I knew and i am missing out on one important thing. Can anyone point me out? I dont feel the device(esp) is faulty. :thinking:

0 Likes

#2

What version of the ESP8266 core are you using?
If it’s anything later than 2.4.2 then downgrade and try again.

Pete.

0 Likes

#3

Sorry for the late reply.
Now the core i am using is 2.4.2 , I had tried with latest cores as well, but it gave more trouble. So i reverted back to 2.4.2
To check, i installed one more local server on pi zero and a diff router as well. Now the same ESP12E is connecting to the new server setup but not to the old once, but there are 2 devices running on it without any problem.AND ONE MORE PROBLEM IS THE DEVICES KEEP DISCONNECTING AND RECONNECTS. SOMETIMES IT WILL BE CONNECTED FOR A WEEK. AND SOME TIMES EVERY ALTERNATE DAYS IT DISCONNECTS. (auth tokens are changed accordingly). Now i am confused is it something to do with the local server or wifi router. To check this i tried connecting to the cloud server, but no luck serial monitor says connecting to cloud, but it doesnt connect and before that there is a line where in it should show it has been connected to wifi but this line is totally messy((#$@$%*#&**^) something like this. So i am assuming that the module is not at all getting connected to the router, so its far from connecting to blynk cloud. The ssid and passwords are correct. Is this something to do with the Firmware of the ESP12E or ESP core ?

0 Likes

#4

I think you should use: Example —> Blynk -> Boards Wifi -> ESP8266 StandAlone SSL ("#include <BlynkSimpleEsp8266_SSL.h>")

0 Likes

#5

Sure i will try once i am home. But i feel it doesn’t make any difference, because nodemcu sometimes connects connects with the same code that i am and i was using from such a long time. And it uses the same ESP12E chip that i am using now. Is there any thing that i am missing out on ? Please correct me if i am wrong.

1 Like

#6

could you try with static IP?
I had have the same issue due to DHCP.
all is fine since I used static IP.

0 Likes

#7

Now i am noticing something weird !!! When i turn on the ESP12E , on the serial monitor it will say connection to cloud or local server to what i have told to do! Meanwhile the ESP12E are being shown on the list of WiFi hotspots available around me in my laptop and as well as my phone. (ESP_C137) something like this.

I had installed Python for the OTA updated is this happening because of this or because of this behaviour , it is not connecting to my local or cloud server as I mentioned in the earlier posts!?

0 Likes

#8

This is normal.
Add this line towards the end of your void setup to stop it:

  WiFi.mode(WIFI_STA);

I don’t understand the rest of what you’ve said.

Pete.

0 Likes

#9

Ok i will try that out.

The whole things is the ESP12E doesn’t connect to the local or cloud server. I will take somewhere around 2min and then connect. And this connection will not be stable. There will be interruptions every 2 or 3 days. What is the reason for this ? I have UPS so no power cut downs what so ever. Then why is this happening?

The first and foremost things is the ESP12E will not connect to cloud nor local server. Is this because the router is not assigning ip ? Because the same ESP12E will sometimes connect with another router :thinking:

0 Likes

#10

Hello !

I am failing again and again. The ESP12E is not connecting to local nor the cloud server

the serial monitor output looks like this


But when i check in the router login page, the device seems to be connected to the router. To check, i also turned off the esp and refreshed the device list and the esp will disappears, and appears back once turned back on. Meaning the esp is connecting to the the router.

Is it something to do with the RPI server ?

Please help me out… :sweat:

0 Likes

#11

Can you post the code you are using at the Esp?

0 Likes

#12

Bro I knew someone would definitely ask me to post the code and later when i post, someone will point out my silly mistakes and i will left in shame :sweat_smile:

That is why i used the basic Blynk sketch and even that doesnt connect to the cloud or Local server. Take any ex sketch or (check physical button) for nodemcu , i is not working. Only after trying all this options i am posting my problem here…

But the same sketch was running fine before so i had that saved. And now i am trying to upload the same (auth token taken care) but it is not working. But there are two nodemcu that are running the same sketch and is connected to the same local server that now i am trying to connect with the ESP12E…

I am not able to understand where the hell am i loosing my way…

0 Likes

#13

Is your ESP12E a regular dev board, or something that you’ve put together?

Pete.

0 Likes

#14

ESP12E

This is the module that i am using. This is powered by a 5v 3w power supply with smoothing capacitor and using AMS1117 3.3v 500mA voltage regulator to step down the voltage to 3.3v ,and again smoothing capacitor to smooth out if any spikes. Pins which have to be pulled up or pulled down has been carried out with 3k3 and 10k resistors. I am feel that hardware side don’t have any problems. And the output pins(GPIO) are used to turn on with opto isolator PIC817 to drive any transistor or mosfet or even a MOC(Triac driver). So there is no interference with the ESP12E.

Even if it connects 1 out of 15 times it will connect just for a sec. And stops working.

I suspect
Blynk library (re installed twice running [0.6.0])
ESP866 core (2.4.2 using now)
Local server (server-0.36.5-java8.ar)
Arduino IDE (1.8.7 using now)

Extra Info
Router TP-Link
Local Server RPI3
Blynk app version (2.27.5) Android
Blynk app version (2.26.0) IOS

0 Likes

#15

There’s one of the GPIO pins (I can’t remember which and I’m posting this from my phone at the moment) that will prevent Wi-Fi from working if it’s pulled LOW/HIGH (can’t remember which).

That would be where I’d start looking.

Pete.

0 Likes

#16

image
@PeteKnight
This is the pin config that i am using.

For programming GPIO pin 0 is pulled low and for running normally it will be left floating.

By doing the above mentioned config, the code can be uploaded. Or run normally.

I am not sure if anything is wrong in this.

0 Likes

#17

@PeteKnight Hello !
I forgot to mention one more point,

As i said earlier, i had this 2 devices running the same code, but these dont show up on the wifi hotspot list, as it these 3 devices showing up… Why is that so ?

I have not made any changes in the code. It’s just the Arduino ide, core, or the blynk library. Causing the esp to turn in to an hotspot. Because i had to re-install my OS. Then i was not knowing what core, Blynk library or ide version i was using. I am feeling the either of this is causing the problem that is why the device is not stable despite having the same code running.

In short the same code was uploaded 2 months back and was working fine( esp was not shown on wifi hotspot list)

But now

Uploading the same code, not even a single line change has been made. And causing the esp to turn into hotspot and unstable.

I am trying hard to explain as much as possible, sorry for my bad English and bad explanations.

Can you figure out what is the cause? Because i have tried all the way which i felt may have went wrong.

0 Likes

#18

@Madhukesh

I had similar problems when I progressed my project from using a NodeMCU to a dedicated ESP8266 module.

The first thing I found was that you need to add:-

WiFi.mode(WIFI_STA);

if not then the ESP8266 will default to AP+ST and will be visible and accessible!

I can’t help you with local server issues as I only use Blynk cloud.

Here is a copy of my circuit that works well for me. (sorry about the rough sketch)

I have now progressed onto using ESP32’s for my project, they are much better. Two cores, one used for WiFi stuff and one for the main program, plus loads more I/O pins.

Richard

0 Likes

#19

Yes I added this line at the end of void setup() as @PeteKnight told in the earlier post.
But still the ESP12E module is not connecting to the cloud/local server.

But now this is solved. The ESP’s are no more visible has hotspot.

But this did not solve the connection issue. It only comes on randomly once out of 15 times or so. And stays online for less then a sec and again looses connection. And keep trying to reconnect every 30sec. And after trying for like 10min or so it will or may come online and stay for 2min but during this time when i turn on or off the GPIO with the Blynk app it is slow as a TORTOISE to respond. And clicking the same Virtual button on the app multiple times will force the device to go offline. And will never come online again.

@rha10
Can you please tell me what versions are you using right now ??

I will try the same as yours and see if the problem goes away.

Thank you very much for the sketch.

It is not only with the local server… It is also not connecting to the Cloud server as well…

WiFi.mode(WIFI_STA);

Before i did not had this line in my code, but even then the esp’s never showed up as hotspot. Only after i reinstalled my OS this problem started , because i dont remember which CORE or Blynk Lib i was using. Can you please help me by saying the version you are using ??

0 Likes

#20

You seem to be focusing a lot on the fact that the name of the ESP was appearing in your list of access points.
This is very normal and doesn’t prevent the ESP working correctly.

You actually only have to run the WiFi.mode(WIFI_STA); command once for a device and it will prevent it from broadcasting it’s name. If you re-flash it will the “erase flash - all flash contents” option selected then you would need to run the WiFi.mode(WIFI_STA); command again if you didn’t want to see the device name appear again.

I think you’ll find that your issue is hardware related. If you look through the various YouTube videos about designing your own ESP12E based devices then you’ll see that they are very fussy about the external circuitry.
I’d say that your resistors are a bit low in value and that you’re missing a couple of smoothing capacitors (located as close to the chip as possible), but that’s only based on read/watched, not on personal experience.

Pete.

0 Likes