Android Home Screen Button Widget not working

Hey blynkers!
I recently updated the blynk app and since the update my home screen widgets are longer working. When I open the project everything works as usual, I just cannot get the button widget to work anymore.

I am using a local server from a raspberry pi 3, Android 8.0 on a Google pixel 2, and blynk 2.17.0.

Like I said, everything was working fine until I updated the app on December 1. Any suggestions? Thanks!

did you tried deleting and re adding the widgets?

I haven’t deleted them because the energy is nonrefundable, but I did create a new one, but it also doesn’t work.

you said it is on local server, so the energy is for free, isn’t it?

Not quite. I have a large supply of energy, but it’s still limited. That being said, I could (and have thought about it) deleting and recreating the widget, but wouldn’t just making a new widget accomplish the same propose?

not sure about this. maybe @BlynkAndroidDev will take a look into this issue…

If you are running you own Local Server, then it is NOT limited, except by your imagination :wink:

image

Delete, replace, and test away to your hearts content.

PS, make sure you are fully updated with LS, App and Library versions, as I recall there was some issue with Home buttons at one time recently.

I guess I need to go into my server settings to add energy? Having unlimited energy still doesn’t fix my widget however.

This might help in that process…

Figured out how to add more energy on my local server, good to know!

I’ve also updated to server 28.10 and reinstalled the app on my phone. Still cannot get the widgets to work. Any other ideas?

Have you tried to re-add it yet? I just tried to add a button and then a display… But, while it did take me to my projects and lets me scroll through them, it will not actually let me pick a widget to associate with Home Screen widget… just wondering if the same thing happens for you?

Ya I can add the widget to my home screen, and it toggles the widget when I touch the button, it just doesn’t toggle the relay that the button is connected to.

Well, you got further then I did :slight_smile:

Ha i thought an update would come out to fix it, but since I haven’t seen anything for a couple weeks, I thought I’d post here and see if there was an good advice. I guess just let me know if you figure anything out and I’ll do likewise!

I updated your topic category.

Thanks for the report. We will check. Did you change http API ports?

Is it still the same with 2.17.1 build?

Everything works like normal now. Thanks!

1 Like

please do not forget to change topic categoey to solved!