Android drops wifi when esp is connected

I have an ESP8266 running a very simple scetch (not that it matters) which sends the wifi strength 2times a second to my local server (tried with offical it is the same). If the esp connects to the wifi within seconds internet is gone from my phone and switches to 4g, but only only when it has the blynk app running. If I kill the app the wifi works for hours. I can than restart the app which will work for a random ammount of time when the issue comes back.

My setup is: Esp connected to a wireless network with fixed ip from router my phone gets a different ip. The server is on the same wireless network with a different ip again.

Didn’t get it. Does your phone connected to ESP wi-fi or you have separate router?

I updated with my setup, do you need anything else?

What Android device do you have and which Android version?

I have a nexus 5 with cm13 but it does the same with factory 6.0

It is a very strange and abnormal behaviour. Could you check the situation when the smartphone is connected to another wireless router? The only reason of such behaviour, which i could think of, is some problems with socket connection on the router, as esp uses socket connection and our app is also using it.

What do you mean by another router? Everything works, I can connect from 4g to my server.

One strange thing is when this happens my phone gets ip address when clearly everything is on the 192.168.1.x range. No other device is affected by this.

I have narrowed it down when it happens. If the app has to reconnect for the server AND the esp is running I can 100% reproduce the error. If the server isn’t running or the app timed out and tries to connect it is the same.
The app says: Sorry, Server can’t talk now and than switches to 4g because no internet on wifi

You could be sure, that we doesn’t control anything with wi-fi settings from the app, we even doesn’t have permissions for such actions. Probably, the problem is on the side of the router and simultaneous socket connections to one server: i don’t remember is esp using ssl connect or not, but app uses ssl socket connect - maybe it is the point (two socket connections to ssl and not-ssl), where such strange behaviour originate.

@Meridani as additional option you may just try to restart router. For some users it helps.

Restarting didnt helped. Now someone arrived so i could test with other devices. Only my nexus does this, can this be related to that it has a static ip in the router?

Yes. And especially with this

Please try maybe to assign some other IP? Just as option

It didnt helped. Wifi still dc.
This is my routers client list (S: server N:nexus) It doesn’t change after my phone dc-s. My phone says its IP address is but in the router it isnt.

I can’t ping it but as soon as I power down the esp it reconnects and responds to pings.

Without the app rebooted everything Still only my phone gets dropped out. If I dont use the blink just normal esp this isnt a problem. What can I do to narrow the problem down?

I think I have the solution. When the esp “connects” to the wifi in reality it makes a wifi with the same ssid so my phone roams to it when it gets to close and overwhelms the routers signal. How can I connect only?

Has this ever been solved? I am having the same problem. My phone keeps switching it’s connection to the Sparkfun Blynk Board. The phone I am using is a Galaxy S3.

@BlynkAndroidDev could you please take a look? Thanks.

@ad-astra this issue is already fixed, just wait for the next release.