analogInputToDigitalPin not defined with IDE 1.6.7 after upgrade

My blink app has been working for weeks, updated to IDE 1.6.7 and now no longer reads from analog pin. I get message below when I upload

C:\Users\Computer\Documents\Arduino\libraries\Blynk/BlynkApiArduino.h:100:6: warning: #warning “analogInputToDigitalPin not defined => Named analog pins will not work” [-Wcpp]

 #warning "analogInputToDigitalPin not defined => Named analog pins will not work"

This warning is probably unrelated…

I dont get that error with version 1.6.1 so there appears to be a compatibility issue with the newer IDE.


I should mention its a Yun and its not just a warning, it doesnt upload unless i go back to 1.6.1. Once I do the sketch uploads and works again with Blynk.

#warning “analogInputToDigitalPin not defined => Named analog pins will not work”


I’m having the same issue. Anything new on this?

Are you using the latest IDE 1.6.10?

I am now, but the warning remains the same. It is pointing to BlynkApiArduino.h. The Yun still won’t talk to the Blynk App

P.S. Thanks for the reply :wink:

This warning is harmless the problem must be different

One year later and I upgraded to 1.6.10 and still the same error messages with the Yun went back again to 1.6.1 :wink: to get rid of the errors.

1.6.10 is very buggy and should be avoided, have you tried 1.6.12?

Yes, same issue with the Yun.

Regarding analogInputToDigitalPin - this warning should not affect anything.
Let me check with my Yun, on the latest version…

Yea, and please let me know if you can read the values on any pins, digital or analaog. I can send cmds to turn pins on and off, but cant read any values.

Update. I have tried every IDE version from 1.6.1 to 1.6.7 with the new Yun library. I can turn Pins on and off with Blynk but cant read any pins using Blynk, I have confirmed that the input pins are working and reading voltage but nothing is coming through the blink ap I am attempting to rebuild the blynk app I had which was some how removed from the blynk server and now need to start from scratch but seems like either I have had a major brain melt down ( which is possible) or there is a compatibility issue with the Yun. Even a very basic attempt to read a pin with blynk on a widget shows nothing, not even “0”. I have put dozens of hours into this at this point. Can some one simply confirm that the current " BlynkSimpleYun.h" works correctly and allows the reading an displaying of pins. Thank you,

I have tried with Arduino IDE 1.6.11, and everything works as expected.
Value display is showing A0 pin value correctly.
I saw some warnings, and now they are fixed on the latest master branch.

Arduino 1.6.12 IDE is also working well for me…

Solved. Today tried again after downloading the new 4.0 Blynk Library and all worked perfect with 1.6.12 IDE