Adafruit nRF8001 connection problem

Edit: I am using Blynk on my IPhone 6S.
I have the nRF8001 breakout board from ADAFRUIT. I can’t get the Blynk app to see the ble device. Here’s my setup:
Atmega328P-AU on a custom PCB, including the nRF8001 on pins 10, 2, & 7

When I run the example sketch by adafruit, “echo demo”, and include the line:
BTLEserial.setDeviceName(“Test”); /* 7 characters max! */

Then, in the Blynk app, when I add the BLE device and try to connect, “Test” shows up.
But when I run the example sketch from Blynk, and then goto connect, nothing shows up to connect to. I have deleted the libraries, reinstalled them using the library manager, but no change. I tried commenting out the include spi.h line like I read about in one post.
Here are the 2 sketches exactly as described. The echo test one will cause the BLE to show up (it also is visible as "Test"Adafruit’s BLE app). And the example sketch from Blynk called “Adafruit_Bluefruit LE” It causes nothing to show up when trying to connect. (It causes nothing to show with Adafruit’s BLE ap). I’ve also tried another example sketch from the blink library called nRF8001 with the same results. I’ve tried resetting my authToken a couple times and emailing it.


The echo sketch from adafruit that causes the nRF8001 to show up:

This is an example for our nRF8001 Bluetooth Low Energy Breakout

  Pick one up today in the adafruit shop!

Adafruit invests time and resources providing this open source code, 
please support Adafruit and open-source hardware by purchasing 
products from Adafruit!

Written by Kevin Townsend/KTOWN  for Adafruit Industries.
MIT license, check LICENSE for more information
All text above, and the splash screen below must be included in any redistribution

// This version uses the internal data queing so you can treat it like Serial (kinda)!

#include <SPI.h>
#include "Adafruit_BLE_UART.h"

// Connect CLK/MISO/MOSI to hardware SPI
// e.g. On UNO & compatible: CLK = 13, MISO = 12, MOSI = 11
#define ADAFRUITBLE_RDY 2     // This should be an interrupt pin, on Uno thats #2 or #3

    Configure the Arduino and start advertising with the radio
void setup(void)
  while(!Serial); // Leonardo/Micro should wait for serial init
  Serial.println(F("Adafruit Bluefruit Low Energy nRF8001 Print echo demo"));

   BTLEserial.setDeviceName("Test"); /* 7 characters max! */


    Constantly checks for new events on the nRF8001
aci_evt_opcode_t laststatus = ACI_EVT_DISCONNECTED;

void loop()
  // Tell the nRF8001 to do whatever it should be working on.

  // Ask what is our current status
  aci_evt_opcode_t status = BTLEserial.getState();
  // If the status changed....
  if (status != laststatus) {
    // print it out!
    if (status == ACI_EVT_DEVICE_STARTED) {
        Serial.println(F("* Advertising started"));
    if (status == ACI_EVT_CONNECTED) {
        Serial.println(F("* Connected!"));
    if (status == ACI_EVT_DISCONNECTED) {
        Serial.println(F("* Disconnected or advertising timed out"));
    // OK set the last status change to this one
    laststatus = status;

  if (status == ACI_EVT_CONNECTED) {
    // Lets see if there's any data for us!
    if (BTLEserial.available()) {
      Serial.print("* "); Serial.print(BTLEserial.available()); Serial.println(F(" bytes available from BTLE"));
    // OK while we still have something to read, get a character and print it out
    while (BTLEserial.available()) {
      char c =;

    // Next up, see if we have any data to get from the Serial console

    if (Serial.available()) {
      // Read a line from Serial
      Serial.setTimeout(100); // 100 millisecond timeout
      String s = Serial.readString();

      // We need to convert the line to bytes, no more than 20 at this time
      uint8_t sendbuffer[20];
      s.getBytes(sendbuffer, 20);
      char sendbuffersize = min(20, s.length());

      Serial.print(F("\n* Sending -> \"")); Serial.print((char *)sendbuffer); Serial.println("\"");

      // write the data
      BTLEserial.write(sendbuffer, sendbuffersize);

This sample code from Blynk causes the BLE device to not show up:

 * Blynk is a platform with iOS and Android apps to control
 * Arduino, Raspberry Pi and the likes over the Internet.
 * You can easily build graphic interfaces for all your
 * projects by simply dragging and dropping widgets.
 *   Downloads, docs, tutorials:
 *   Blynk community:  
 *   Social networks:  
 * Blynk library is licensed under MIT license
 * This example code is in public domain.
 * This example shows how to use Adafruit Bluefruit LE nRF8001 breakout
 * to connect your project to Blynk.
 * Note: This requires BLEPeripheral library
 *   from http://librarymanager
 *   or
 * NOTE: BLE support is in beta!

//#define BLYNK_DEBUG
#define BLYNK_PRINT Serial


#include <BlynkSimpleSerialBLE.h>
#include <SPI.h>
#include <BLEPeripheral.h>
#include "BLESerial.h"

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "443a7dae08294ea0a4314d3d2492a181";

// Define pins (varies per shield/board)
#define BLE_REQ   10
#define BLE_RDY   2
#define BLE_RST   7

// Create ble serial instance, see pinouts above

void setup() {


  Blynk.begin(auth, SerialBLE);

  Serial.println("Waiting for connections...");

void loop() {

  if (SerialBLE) {    // If BLE is connected...;

(There are 2 other tabs on the example sketch, but I changed nothing on them)

Wow, nobody can help this guy? I’m running into the same thing.

@SDC Unfortunately, it appears there was no further action here, but as you already have a topic created for your issue, please keep to that topic. Thanks.