A classic one : Arduino + Iphone + nrf8001

The UX in general is slightly different on Android and iOS platforms, good designers never blindly copy.

But regarding this particular button, I believe @Pavel just didn’t like how 3 buttons in a row (and title shifted) look on iOS. But I may be wrong.

I misunderstood! I did try to add a BLE widget (was looking into iphone widget)
So I tried again and it is able to find UART with BLE widget in first attempt but it does not connect. If i try a second time after failed it doesn’t find UART anymore. Then, when I launch the project, Blynk doesn’t tell me "device is offline"So I guess iphone is connected to the nrf800…
I also check again that I can connect and send byte with nRF toolbox provided by the manufacturer of nrf8001 and it works.
Following vhymanskyy’s link, I did restart the phone without success.
I really appreciate your help and I keep faith in a success!

1 Like

Please post here exact models and model versions of your Arduino and nrf8001

Genuino uno
Adafruit nrf 8001 BLE
IDE 1.8
Blynk release 4.4 2
Adafruit nrf8001 library from 27/05/2016 (latest I found)

I too am not able to connect the Adafruit nrf 8001 BLE. And today I got a bluetooth Bean from punchThrough. There’s an example sketch for the Bean in the blynk example folder, so I had my hopes up. But I can’t get it to work, either. Does anyone have ANY kind of bluetooth peripheral, breakOutBoard, BLE type device that they’ve gotten to work with iOS Blynk?

I’m still not able to connect my adafruit nrf8001… If you find a working BLE device with IOS and arduino, I’ll be very interested :slight_smile:

We hear you guys. I will get a BLE module in a few days and will check on my side.

1 Like

Thank you @Eugene, we stay tuned!

Another question, just in case :
I use Blynk exemple for nrf8001 in BLE connection.
Is that normal that my “Sketch uses 22898 bytes (70%) of program storage space.” (Arduino compiling quote)
It seems to be a lot for a simple exemple…

Hello all!
Do you have some news with adafruit nrf8001?
I just bought a hm-10 witch successfully connect to light blue app but still no luck with Blynk…
I’m starting to lose faith to use Blynk with iOS…

Anyone making any progress on iOS/BLE of any kind of hardware.

Guys, there might be some problem with iOS specifically.
We’re checking this already.

Just so that you know,
I’ve managed to successfully connect current Blynk iOS app with the Bluno from DFRobot.
The Arduino + HM-10 scheme seem to have difficulties.

@SouthernAtHeart @Flyingsoon

I can now confirm that iOS app BLE works as expected. Please update you app to the latest version (should be 2.8.5) and if you still can’t connect, go to the app About page and send me the logs.

Please also make sure your sketch is correct. Double check:

  • RX and TX pins
  • Auth token
  • You path the correct instance of SoftwareSerial to the Blynk.begin() function

As example, here is my working sketch for Arduino+HM-10:

#include <SoftwareSerial.h>
#include <BlynkSimpleSerialBLE.h>

SoftwareSerial softwareSerial(7, 8); // RX, TX
char auth[] = "d3bf837000000000000000072140c6c5";

void setup()
  Blynk.begin(softwareSerial, auth);

void loop()

I just ordered this HM-10 model:

It’ll be here in 2 days, so I’ll let you know how it works. I still can’t get the nrf8001 to work, but if this HM-10 works, that’ll be terrific! I can build my project around it.

Hello All!

I tried your sketch witch and It is working great THANK YOU EUGENE!!!
It would be great to modify the blynk exemple, witch is slightly different.

First it was not working because it depends what baudrate your HM-10 is set!
For me, it was 115200, was not working with 9600.

You could find here a tutorial to change the baudrate :

I didn’t success with this so I did plug my HM-10 to an alexmos 32 board I had at home end Into the GUI, then go to board, Configure Bluetooth and you follow this guide :

Now It is working for me too! Thx for your time, hope this post is going to help IOS users!

I do not go deep into the subject but I read somewhere thzt there are different version of HM-10

I didn’t read the post as the one I got seems to be right one, It is a quite old post from june 2015 :


Hope It is going to help…

First testing of the Hm-10 with IOS is a success! I tried the LCD, a button, and an analog input. If I power cycle the my uno/hm-10 the blink app sometimes doesn’t connect right away, but if I force it closed and restart, it always reconnects! Thanks so much! This opens a LOT of possibilities.

6 posts were split to a new topic: softwareSerial was not declared in this scope