BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

zeRGBa widget not working well

localserver
esp8266

#1

Hi Blynkers!

I am using latest blynk app, latest server build, latest Blynk library and esp8266 library.
On esp8266 (wemos D1 mini) i am running clean latest Blynk Blink example sketch, where i changed only token, wifi credentials and blynk.begin() to connect to my private server. Next I have connected RGB LED to esp.

On Blynk app, i have zeRGBa widget running, and RED, GREEN and BLUE sliders in parralel on the same pins (note that issue happens even if those pins are used by zeRGBa widget only)

Now, I discovered (it may be one of that things, that appears and disappears out of nowhere) that if i am setting any color on zeRGBa, LED does not flow trough colors smoothly, and change only to about five colors (in other words, i can not set REALLY ANY color, that i want). Also, it does not fade. I mean, as you go lower in the zeRGBa widget, LED should got less and less brighter until is dark completly. But intead of this, is LED either turned on completly, or turned off completly. Nothing between. (This issue started o happen only few days ago. also it happened to me on 2 Wemos D1 mini-s and one Arduino UNO. IDK if is somehow repeatable.)

It is a little hard to describe this in words, so i made a video. Maybe little long (2+ mins) but it will explain my problem better i think…
Video (can not be played online - sorry for that) (on mega.co.ng) 110.8 MB

If you want some logs or something like this, I will try to satisfy you.


#2

Please double check the zeRGBa settings… as per another topic made just today, the MIN / MAX default settings might have changed. I believe they used to be 0-255 and changed to 0-1023. Granted, 0-1023 is the correct range of an ESP8266 PWM pin.

Depending on the type of RGB LED you are using (common cathode or common anode) you might need to reverse the settings to get the desired results


#3

OK, looking at your video it seems you have the mostly correct range… Off is Off and White is White, and the colours seem correct, but the intensity does seem off.

Hard to tell which pins you are using though… but you say this was all working properly before?

What is the code you are using? It looks similar to one of my examples… and I did have some mathematical adjustments in the code to account for range differences between devices. Please post it here and format it correctly as required…

Blynk - FTFC


#4

As i said before, i am using clear BlynkBlink example sketch:

#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "DoesNotMatter";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "DoesNotMatter";
char pass[] = "DoesNotMatter";

void setup()
{
  // Debug console
  Serial.begin(115200);

  Blynk.begin(auth, ssid, pass, IPAddress(DoesNotMatter), 8080);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "blynk-cloud.com", 8442);
  //Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,100), 8442);
}

void loop()
{
  Blynk.run();
  // You can inject your own code or combine it with other sketches.
  // Check other examples on how to communicate with Blynk. Remember
  // to avoid delay() function!
}

Also, did i mentioned, that if i use sliders instead of zeRGBa, It is working fine? Anyway it is on the video, so… you could saw it. Pins on the video, I using, is: D5,D6,D7,D8… D7 acts like GND, so other pins is not inverted. Range is correct. And yes, it was working few days ago, like a charm.


#5

OK, so you are using direct pin control, not virtual pins… Yes it can work, but not as good as proper code and digital pin commands in my opinion.

I couldn’t tell that your sliders and zeRGA were separate as it looked like they were getting feedback with each other… but that could have been due to recent changes with shared pins (assuming digital pins are included in that) thus it had similarities to some of my example code, so your statement of using BlynkBlink wasn’t enough to make me sure :wink:

Try it out…

Possibly due to the default range settings in the zeRGBa… try switching them back to 0-255

PS, Best to use a proper GND pin and be aware that D8 has a built in 10K PD resistor on the Wemos D1 Mini


#6

Okay, so… Used your code, changed auth, wifi, ip and pins, and… blynk does not run. esp is just restarting every about 3 seconds… on serial is only:

 ets Jan  8 2013,rst cause:4, boot mode:(3,6)

wdt reset
load 0x4010f000, len 1264, room 16 
tail 0
chksum 0x42
csum 0x42
~ld

so…IDK what is going on…

I NEVER used range 0-255 for PWM on esp8266, and every time it worked (with 0-1023 range). Besides of that, i tried to change value range in zeRGBa to 0-255. Seems to nothing to changed at all. Issue still persist as before.


#7

Sounds like bad wiring, pin choices, old core version… who knows. I do know the code works fine.

Well I have no other idea, sorry.