BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

ZeRGBa not dimming (direct digital pin control)


#1

Since the second to last update the ZeRGBa widget doesn’t dim my led strip anymore, it’s either on or off. I use digital pins (I love the simplicity) and it always worked till that update. (Nothing changed on the hardware side of things)
All my libraries are up to date and the led strip dims perfectly with a slider widget.


#2

What is your smartphone OS and version? Could you attach screenshot of zeRGBa widget’s settings?


#3

I’m running the latest Android version (2.24.0).
Here’s a screenshot:


#4

Thanks, we’ll check on our side and fix it in the next release


#5

Awesome! Thanks a lot!


#6

This must be a direct digital pin control issue as virtual pins still register the ranges properly.

@Yorick_de_Munnik if you wish to explore using code for your zeGBa and slider RGB control, here is some code I wrote.

C++ Blynk - Code Examples for Basic Tasks (Work in Progress)


#7

We had checked on our side - seems everything is fine with sending value from RGB widget with digital or virtual pins.


#8

@BlynkAndroidDev Actually, I just tested with an UNO, zeRGBa and sliders on direct digital pins as well…

1st observation, I didn’t know you could share digital pins with the App as well… I thought it was just Virtual pins. AND they synchronize between the zeRGBa and slider widgets!! Nice! :100:

2nd observation, The OP is correct, the zeRGBa only registers a signal at the extreme end of the range: 0 OR 255 (or perhaps just registering on the MAX range?.. I was using a common Anode RGB LED so I needed to invert my range settings). Sliders work as expected.

I also tried it without the sliders, in case there was some conflict… same issue.


#9

Yep, I see now. Values has been sent correctly, but the write command has not been correct for RGB.

I’ve made a logging test build with this fix: https://www.dropbox.com/s/iz63b0b09ow8e2b/blynk_log.apk?dl=0 (you should remove your current app’s build to check this one)


#10

Brilliant! This version works perfectly!