Your Arduino Nano is not in Network

Hi.

Have you changed something because my project isnt working anymore. I have used it before server went down, and after that I stopped testing it because I ordered PCBs from manufacturer. Now im trying to use it again and its not connecting to server. Not prototype and not pcb version…

My project is basically esp shield with arduino nano with hardware serial, for the communication part at least. It seems to connect and hearthbeat is working and it seems that esp is doing something (blue blink now and then). Unfortunately I cant debug it via serial because i have used all my ports to the project so I just ask what I should change in my project that it will connect again. I havent changed anything in the code, just waited to PCB to arrive…

I have tried several ESPs and updated library to the newes one and reflashed arduino several times… no success… And re installed the Blynk app to the phone again, no success. :frowning2:

-Vellu

Hello. Are you using latest blynk library?

Yes. I’m using newest.

-Vellu

We need to see serial output in order to understand what is going on. Please show it. Also there is a small chance your router cached old Blynk host, restart may help.

@Vellur please try also this :

Blynk.begin(auth, SSID, pass, "blynk-cloud.com");

Does that help?

I done the changes to my code what has been done to esp shield example, but no success.

    #include <ESP8266_Lib.h>
    #include <BlynkSimpleShieldEsp8266.h>
    #include <SimpleTimer.h>

    // Set ESP8266 Serial object
    #define EspSerial Serial

    // Your ESP8266 baud rate:
    #define ESP8266_BAUD 9600

    ESP8266 wifi(&EspSerial);

    // You should get Auth Token in the Blynk App.
    // Go to the Project Settings (nut icon).
    char auth[] = "";`

    void setup(){
      lcd.begin (16,2);
      //Serial.begin(9600);
      delay(10);
      EspSerial.begin(ESP8266_BAUD);
      delay(10);
      Blynk.begin(auth, wifi, "", "");
    }

I think that is most important part of the code

edit: that was hard to put it to code format :smiley:

…and that “blynk-cloud.com” didnt help… :frowning: