BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

You can't set higher permissions than your current role

Hi,

I just upgraded to Pro and am trying to tune down the rights for the users.

Our setup of organizations will be that there can be multiple sub-organizations with each multiple users and multiple devices.

All users should only be allowed “view” and “control” rights on all devices (I will keep on managing anything that needs to be changed in all sub-organizations).

I am logged in as (root) admin and try to deselect “Edit devices” for the users

but when I click apply I get a notice: “You can’t set higher permissions than your current role”

I can change the user right “Provision new device”…

Regards,
Jeroen

@i-connect hello. Do you change the single permission during your edit or do you also change other permissions?

@Dmitriy

At first I did multiple changes at once but when that did not work I cancelled it and tried to edit only “Edit devices”.

Just tried again changing only that permission and got the same error

Hm. Thanks. Could be a bug. We’ll check.

@Dmitriy any progress on this? I just tried and had same result. I need to to further configure the organization setup for my client(s)

@i-connect hello. Bug confirmed. Already fixed. Will be available after the next deployment. Probably this Tuesday.

@i-connect should be fixed now.

just tested, I am now able to change device rights for users without getting the "You can’t set higher permissions than your current role” notice

thx!