WTH am I doing wrong?

I’m using an arduino uno, tinysine bee shield v1r1 wifi shield, with a wifiBee v1r1 from tinysine electronics wifi module.

I tried the Arduino_wifi and the TinyDuino_wifi examples.
I can get the former to load, but the iPhone app says the Uno is offline
The latter doesn’t load, just gives a no such file or directory error

I’m sure I’m doing something silly or dumb, maybe someone else can point it out quicker than my lame ass can see it?

jason

Did you install the Adafruit CC3000 wifi libraries? I think you need those to compile the tinyduino example.

Here is my hardware… On an UNO board
Tried the CC3000 library and a couple others
I’m able to upload to the arduino without errors, but when connecting through the blynk app, I get a message that the arduino is offline.

Im not sure which example I should be starting with, based on my hardware?

You need this sketch. Instruction is in comments of sketch.

Thank you, seems to be closer to working now, just need to test when in range of the wifi signal…
Also, I had to change a couple pins assignments on my lcd, specifically 3,5.

Still no worky.
Blynk error message is “Arduino is offline”

Only changes I made to the above linked sketch was the Token, password and ssid.

Anything else I may have missed in the setup?

EDIT:

#include <BlynkSimpleCC3000.h>

I did just notice that I don’t have BlynkSimpleCC3000 listed in my library list… All other libraries are.

Second EDIT:
All I can find fro BlynkSimpleCC3000 library is a single file…
https://github.com/blynkkk/blynk-library/blob/master/BlynkSimpleCC3000.h
Is this correct?

Yes. You don’t need to go to these files usually. Just example folder. So if app is saying arduino is offline - something went wrong on hardware side. Please try enabling debug and show us output.

Just activated debug, and there is no output in the serial monitor

Suggestions?

Edit
If I comment out the line Blynk.begin…
Then serial monitor works with standard serial.print commands.
When blynk.begin is enabled, serial.print no longer works at all

Could there be another example sketch to start with?

Edit2
Just switched over to my Mega board, and get the same results…
Blynk app shows Mega is offline
No serial output

Also, yesterday I ran the Tiny wifiBee setup tool.
LED D1 is steadily blinking as it should, but I still haven’t confirmed functionality with out using Blynk

This is what I found: “Tinysine WIFI shield based on Roving Networks RN-XV module”.
This means you need to use RN_XV_WiFly example (at least)!
But first, you need to get your basic hardware setup running without Blynk, to identify any problems.