BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Widgets (e.g. time input. menus selection, slider) located within device tiles being reset to blank on android phone

Hello @BlynkAndroidDev and @Dmitriy .

You may remember a year or so back I had this issue. We really never got to the bottom of it.

I believe I can recreate it now. Can you you let me know what I can send you so you can try to locate the problem.

There doesn’t appear to have been an update to the phone app for a while and my question concerning time input when there is a change to daylight saving has gone unanswered. So I’m just wondering now that Blynk has become commercial and is almost entirely focusing its attention on the new platform you are not that interested in supporting the phone app anymore. Let’s know please.

Regards

Hi,

You can install Blynk Beta on Android - it has logging support, so if it is possible to recreate this issue - please send logs afterward.

There will be soon a new update, but it is mostly for Video and GPS widgets, and because Play Store updates are now required to proceed review, and comply with additional policies due to GPS widgets (location data in a background) - it takes more time than expected.

Thanks for the reply. I’ll try in the next 48 hrs. Please remind me how to send logs. Last time we tried we had no success. It was to do with video so when you release the the version for video fixes I’ll pick that up again to see if my if my issues are solved. I’ve not tried it for a while.

Thanks & regards.

1 Like

To send logs you need to click on the info button in the top right corner of the dashboards list screen. There should be an option to Send Logs - you can try not only to gmail but also to some cloud services to save the logs file (you can send me the result link to it via PM here).

I’ll update you when the new version will be available.

Hi @BlynkAndroidDev

I thought I could recreate this :rofl: No luck and has not repeated itself randomly either since the last message. Not doing much on the platform development now anyway as I’m hiding in New Zealand from Covid UK.

Hi @BlynkAndroidDev

OK. I’ve nailed it. I can repeat this error. Most widget under tile pages (time input, value, slider, leds, buttons etc) are set to null on the server :

  1. Switch to developer mode.
  2. Hit the nut button on the tile widget
  3. Exit developer mode
  4. All widgets under tiles appear OK. But I suspect they have all be set to null on the server - just not refreshed yet from server to widget.
  5. Unload blynk
  6. Reload blynk - hence refreshing from server - widget displays are all null for widget under tiles.

NB widget not defined under tile pages are OK.

Let’s know if you need further info. If you need logs then please give me instruction as I keep on forgetting how to do it :slight_smile:

Which app’s version is it?

Current. 2.27.28 26.03.2021

@BlynkAndroidDev

Hi. Any thoughts?

@BlynkAndroidDev

Hello. Are your able to address this issue. I can absolutely recreate it. It’s a problem for me when it happens. I have to go through all my projects and reset the widgets.

Thanks.