Why I cannot connect to the Blynk server

I cannot login to the Blynk,it told me that “Reconnecting to the server…”

Hello. Please try the latest app. What version do you have right now?

I am also facing the same issue since a week. I am using latest versions of Blynk library and Blynk app.

@rajindermath what error do you see? Android/iOS? Local/Cloud server?

It is with respect to Blynk cloud server. It says connecting to blynk-cloud.com:80 and never gets connected and shows login time-out. My projects were running smoothly I think a week ago. I am using latest Blynk library (0.5.2) latest version of Arduino IDE(1.8.5), latest Blynk app(2.20.3). Even for the given examples from sketch builder are not working. I tried using the older versions of Blynk library but didn’t work.

[D][WiFiGeneric.cpp:293] _eventCallback(): Event: 2 - STA_START
666666[D][WiFiGeneric.cpp:293] _eventCallback(): Event: 4 - STA_CONNECTED
000000[D][WiFiGeneric.cpp:293] _eventCallback(): Event: 7 - STA_GOT_IP
WiFi connected   IP:
[6595] Connecting to Tenda_285298
[6595] Connected to WiFi
[6595] IP:

[6607] Connecting to blynk-cloud.com:8442
[9285] <[02|00|01|00] ed2264708bca4ac9b40565680c7c85d9
[9595] >)[00|01|00|11]
[9597] >[00]80
[9597] Redirecting to
[9598] Connecting to
[9899] <[02|00|01|00] ed2264708bca4ac9b40565680c7c85d9
[11901] Login timeout
[14901] Connecting to
[14904] <[02|00|01|00] ed2264708bca4ac9b40565680c7c85d9
[16906] Login timeout

This how the BLYNK_DEBUG report looks like.

Moreover, the same sketch connects to Blynk cloud server when using my mobile hotspot but it doesn’t work with Wi-Fi. What might be the reason? A week ago there was no issues with the Wi-Fi connectivity to Blynk cloud.

Still searching for the solution. Is anybody facing the same issue here?

Actually in the latest Blynk library it should be port 80 and not 8442

Even if i provide 8442 in the sketch it redirects to Port 80. I even tried with port 80, but in vain.

I have the same problem…
connecting blynk-cloud:80 always timeout as result…
Please help to someone who has solution to this problem.

Because I couldn’t connect to the official Web server, I was in China and probably was banned, so according to the online tutorial, I created my own local server to solve this problem.