Wemos D1 Mini Pro as an Arduino uno Shield


I have been trying to configure my Wemos D1 Mini Pro as a shield with my arduino uno. When I get it working I will be changing to an esp-01 and pro mini. I have connected the two boards as shown here and have no success getting them to work. I am reading the output from the wemos board with Termite to see where the problem is occurring. When I turn on the Wemos and the arduino the Wemos start giving out errors. The arduino just stops at Failed to disable Echo. I also tried to read the commands the arduino was giving the esp with a separate usb to serial and then writing manually the commands to the Wemos board. I always get error. I think the firmware I am using is the problem. I tried using SDK version 1.5.4 and some other firmware but I forgot them.

This is what the Wemos board says when connected to the Arduino and reading the serial of the Wemos.

This is when I connected a seperate USB to serial to the arduino.

Has anyone had this problem and does anyone know how to fix it?

Pretty sure mux errors are referenced on this site. mux is a bit of short reference to search for though.

The Wemos board is giving the is error when I enter the command AT+CIPCLOSE=1. It gives out error and MUX=0. I tried sending this command also. AT+CIPMUX=1. It replays with OK and when I reissue the command. AT+CIPCLOSE=1 it gives back UNLINK and ERROR